When Camera in Landscape mode the status bar shows in vertical mode.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Camera
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: VladimirBelonenko, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 affected, b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark] 2.6UXnom, URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8686836 [details]
logcat_20151112_1450.txt

Description:
User switches to landscape mode in camera app and notification bar appears to be vertically not in landscape mode.

Repro Steps:
1) Update a Aries to 20151112122058
2) Open Camera app
3) Turn to Landscape mode
4) Observe that Status notification bar shows vertically, when camera is in landscape.

Actual:
Notification bar is vertically when camera app in landscape mode.

Expected:
When camera app in landscape mode the notification bar is suppose to be in landscape too.

Environmental Variables:
Device: Aries Master 2.6 kk full flash
Build ID: 20151112122058
Gaia: 27bc9412ca607648bc398b25bb1ae25653b2b278
Gecko: 3cc3b1968524248450c465c4ea2ee5596ffa65f2
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 3/3
See attached: video clip and logcat
(Reporter)

Comment 1

3 years ago
This issue still occurs on Flame 2.6, Flame 2.5, and  Flame 2.2
Result: Notification bar is vertically when camera app in landscape mode.

Environmental Variables:
Device: Flame 2.6 kk full flash
Build ID: 20151112030244
Gaia: 27bc9412ca607648bc398b25bb1ae25653b2b278
Gecko: 3cc3b1968524248450c465c4ea2ee5596ffa65f2
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.5 kk full flash
Build ID: 20151109004552
Gaia: cf646c52bb947af28329b0a100df91d1b1f2a907
Gecko: 4eafef5b80f8985c94c4a067f130d37513e1a581
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.2 kk full flash
Build ID: 20151112032505
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: e772f343b736
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+]
status-b2g-v2.2: --- → affected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [2.5-Daily-Testing][Spark][NGA ONLY] → [2.5-Daily-Testing][Spark]
No-Jun, is this by design? In browser the notification try appears up top in landscape mode.
Flags: needinfo?(ktucker) → needinfo?(npark)
I think it was always like this, and I'm like 80% sure this is not a bug, but for that other 20%, I'll ni? tif for a quick answer.
Flags: needinfo?(npark) → needinfo?(tshakespeare)
It has always been like this and from a design perspective it is definitely a bug. In all other scenarios, the status bar matches the orientation (at least it should).

But with camera, I believe they had to lock the orientation to force the camera controls to stay put which is impacting the status bar. At one point this also affected dialogues (like the delete confirmation from preview). I can't remember if this got fixed.

It would be awesome to fix, but I don't know if it's technically feasible in the current implementation.
Flags: needinfo?(tshakespeare)
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark] 2.6UXnom
[Tracking Requested - why for this release]:

Per comment 4, this is a backlog bug, it's up to aosmond to fix this.
tracking-b2g: --- → backlog

Comment 6

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.