[RTL][Homescreen] the top dots do not match the current active column in RTL

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: kaze, Assigned: cwiiis)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [2.5-rtl-test-run])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8686853 [details]
screenshot

The two dots at the top of the new Homescreen do not work as expected in RTL mode, see attached screenshot.
QA Whiteboard: [rtl-impact][MGSEI-Triage+]
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Whiteboard: [2.5-rtl-test-run]
(Assignee)

Updated

3 years ago
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Priority: -- → P2
Created attachment 8687282 [details] [review]
[gaia] Cwiiis:bug1224385-homescreen-rtl-panels > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8687282 - Flags: review?(apastor)
(Assignee)

Comment 2

3 years ago
Comment on attachment 8687282 [details] [review]
[gaia] Cwiiis:bug1224385-homescreen-rtl-panels > mozilla-b2g:master

Moving review to Michael, Alberto and Guillaume are on PTO.
Attachment #8687282 - Flags: review?(apastor) → review?(mhenretty)
Comment on attachment 8687282 [details] [review]
[gaia] Cwiiis:bug1224385-homescreen-rtl-panels > mozilla-b2g:master

Working well, code looks fine. r=me
Attachment #8687282 - Flags: review?(mhenretty) → review+
(Assignee)

Comment 4

3 years ago
Merged: https://github.com/mozilla-b2g/gaia/commit/85a3002a9b436a4be3f83747a84552dd81ab11b9
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
status-b2g-master: affected → fixed
(Assignee)

Comment 5

3 years ago
Comment on attachment 8687282 [details] [review]
[gaia] Cwiiis:bug1224385-homescreen-rtl-panels > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Panel indicator shows incorrect page and empty-pinned-pages display looks slightly incorrect. Also, possibly other small side-effects with scroll shadow.
[Testing completed]: Manually tested and automated unit testing added.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None.
Attachment #8687282 - Flags: approval-gaia-v2.5?
Comment on attachment 8687282 [details] [review]
[gaia] Cwiiis:bug1224385-homescreen-rtl-panels > mozilla-b2g:master

Approved for 2.5 uplift. 

Thanks
Attachment #8687282 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
This bug has been verified as "pass" on the latest build of Aries KK v2.6 and Flame KK v2.6 512mb by the STR in comment 0.

Actual results: The two dots at the top of the new Homescreen work as expected in RTL mode

See attachment: Verified_v2.6_dots.png
Reproduce rate: 0/10

Device: Aries KK v2.6(master) (Pass)
Build ID               20151118150439
Gaia Revision          cba7e4b86361af31b153cfebaf99900e0b860f7b
Gaia Date              2015-11-18 09:45:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1d6155d7e6c91fa5ec1ef6927f3d3a044187896d
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151118.142334
Firmware Date          Wed Nov 18 14:23:42 UTC 2015
Bootloader             s1

Device: Flame KK v2.6(master) 512mb (Pass)
Build ID               20151119150204
Gaia Revision          94a821b49f4dca3f9321cd80e13c44c4a6696952
Gaia Date              2015-11-19 15:35:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc325db44f6f8a58604d60b746c140e73f3d8216
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151119.182720
Firmware Date          Thu Nov 19 18:27:32 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Created attachment 8689951 [details]
Verified_v2.6_dots.png
status-b2g-master: fixed → verified

Comment 10

3 years ago
This bug has been verified as "pass" on the latest build of Aries KK v2.5 and Flame KK v2.5 by the STR in comment 0.

Actual result: Actual results: The two dots at the top of the new Homescreen work as expected in RTL mode.

See attachment: Verified_v2.5.png
Reproduce rate: 0/10.

Device: Aries KK v2.5( Pass )
Build ID               20151126113601
Gaia Revision          34ccc2c8f17b87a1fab95a4186b0019ec78c7f75
Gaia Date              2015-11-26 09:44:10
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fbaba398bd98fd1837ef2fd7c13ed8ee69640cfb
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.104443
Firmware Date          Thu Nov 26 10:44:51 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 512mb( Pass )
Build ID               20151126113148
Gaia Revision          34ccc2c8f17b87a1fab95a4186b0019ec78c7f75
Gaia Date              2015-11-26 09:44:10
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fbaba398bd98fd1837ef2fd7c13ed8ee69640cfb
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151126.104320
Firmware Date          Thu Nov 26 10:43:29 UTC 2015
Bootloader             L1TC000118D0

Comment 11

3 years ago
Created attachment 8692801 [details]
Verified_v2.5.png

Updated

3 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.5: fixed → verified
You need to log in before you can comment on or make changes to this bug.