[Dialer] The emergency number can't be dialed from contact detail page.

VERIFIED FIXED

Status

Firefox OS
Gaia::Dialer
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Jessica, Assigned: steveck)

Tracking

({late-l10n})

unspecified
ARM
Gonk (Firefox OS)
late-l10n

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 affected, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8687088 [details]
Aries_KK v2.5.3gp

[1.Description]:
[Aries KK v2.5&v2.6][Flame KK v2.5&v2.6] Launch dialer app and enter call log page. Long tap the call log of emergency number and select 'Contact details', the emergency number can't be dialed from detail page.

Time: 1:05
See attachnebts: Aries_KK v2.5.3gp and logcat_0105.txt

[2.Testing Steps]: 
Precondition: There is no SIM card in the DUT.
1.Launch contacts app.
2.Create a contact whose number is emergency number (eg. 911), and dial it from the detail page.
3.Launch dialer app.
4.Long tap the call log you made just now at call log view.
5.Select 'Call Information'.
6.Select 'Contact details'.
7.Tap the phone number to dial.

[3.Expected Result]: 
7.It could dial.

[4.Actual Result]: 
7.Can't dial and there is no any prompt.

[5.Reproduction build]: 
Device: Aries KK v2.5 (Affected)
Build ID               20151110094357
Gaia Revision          07baf613699fa6225359c7f04825c5caeb71d424
Gaia Date              2015-11-09 21:32:50
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/e14287b00a514a15418dfaa89287030c588ad19d
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.090331
Firmware Date          Tue Nov 10 09:03:39 UTC 2015
Bootloader             s1

Device: Aries KK v2.6 (master) (Affected)
Build ID               20151112120735
Gaia Revision          27bc9412ca607648bc398b25bb1ae25653b2b278
Gaia Date              2015-11-12 02:27:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3cc3b1968524248450c465c4ea2ee5596ffa65f2
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151112.112635
Firmware Date          Thu Nov 12 11:26:43 UTC 2015
Bootloader             s1

Device: Flame KK v2.5  512mb (Affected)
Build ID               20151109004552
Gaia Revision          cf646c52bb947af28329b0a100df91d1b1f2a907
Gaia Date              2015-11-09 02:55:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-

b2g44_v2_5/rev/4eafef5b80f8985c94c4a067f130d37513e1a581
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151109.041411
Firmware Date          Mon Nov  9 04:14:26 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.6 512mb (master) (Affected)
Build ID               20151112150206
Gaia Revision          27bc9412ca607648bc398b25bb1ae25653b2b278
Gaia Date              2015-11-12 02:27:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3cc3b1968524248450c465c4ea2ee5596ffa65f2
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151112.183236
Firmware Date          Thu Nov 12 18:32:49 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free test
(Reporter)

Comment 1

3 years ago
Created attachment 8687099 [details]
logcat_0105.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
[Blocking Requested - why for this release]: Calling emergency number should always work.
Although the way to follow to reproduce the problem is long, this should work
blocking-b2g: --- → 2.5?
Triage: blocker, emergency number call should be allowed.
blocking-b2g: 2.5? → 2.5+
Not sure if this is a red herring or not; found these messages in the log: 
11-13 01:05:59.748 W/Communications( 2543): Content JS WARN: L10nError: "#type_l10n_id#" not found in en-US in app://communications.gaiamobile.org/contacts/views/details/details.html 

11-13 01:06:01.098 E/Communications( 2543): [JavaScript Error: "TypeError: file is null" {file: "app://communications.gaiamobile.org/contacts/views/details/gaia_build_defer_details.js" line: 382}]
Adding a contact will trigger : 
11-13 01:05:59.748 W/Communications( 2543): Content JS WARN: L10nError: "#type_l10n_id#" not found in en-US in app://communications.gaiamobile.org/contacts/views/details/details.html 

We shouldn't stop emergency number from contacts without the sim; having said that, after reading the steps, this might be an edge case?  I would have expected that we already create a contact like this anyhow as default... We would have to add an exception of any emergency number being added to the contacts.  NI: francisco.
Flags: needinfo?(francisco)
(Assignee)

Comment 6

2 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #4)
> Not sure if this is a red herring or not; found these messages in the log: 
> 11-13 01:05:59.748 W/Communications( 2543): Content JS WARN: L10nError:
> "#type_l10n_id#" not found in en-US in
> app://communications.gaiamobile.org/contacts/views/details/details.html 

I can find this log when everything works fine with sim, so it seems not the root cause.

> 11-13 01:06:01.098 E/Communications( 2543): [JavaScript Error: "TypeError:
> file is null" {file:
> "app://communications.gaiamobile.org/contacts/views/details/
> gaia_build_defer_details.js" line: 382}]

And this one should be much more critical, will look into this part.
I have the feeling that we may have broke part of the code shared between contact details and call entry detail.

In theory, some countries don't allow to perform emergency calls without a SIM, that's the string that also we are missing, that seems to appear.
Flags: needinfo?(francisco)
Created attachment 8692359 [details] [review]
[gaia] steveck-chung:bug-1224497-dailer-emergency-call > mozilla-b2g:master
(Assignee)

Comment 9

2 years ago
Comment on attachment 8692359 [details] [review]
[gaia] steveck-chung:bug-1224497-dailer-emergency-call > mozilla-b2g:master

You are right that detail entry missed the confirmation-message form for showing the dialog and it will break the following emergency call handling. I only added the form back including moving the connecting string to shared since it'll be shared between dialer/contacts.
Attachment #8692359 - Flags: feedback?(francisco)
Attachment #8692359 - Flags: feedback?(francisco) → feedback+
(Assignee)

Comment 10

2 years ago
Comment on attachment 8692359 [details] [review]
[gaia] steveck-chung:bug-1224497-dailer-emergency-call > mozilla-b2g:master

Ideally it should have a integration test to verify the flow is correct, but I don't think we have proper way to mock/control the amount of sim card in integration test. So I simply added an unit test to verify the existence of the confirm dialog.
Attachment #8692359 - Flags: review?(francisco)
(Assignee)

Updated

2 years ago
Assignee: nobody → schung
Comment on attachment 8692359 [details] [review]
[gaia] steveck-chung:bug-1224497-dailer-emergency-call > mozilla-b2g:master

LGTM, thanks!
Attachment #8692359 - Flags: review?(francisco) → review+
(Assignee)

Comment 12

2 years ago
In master: https://github.com/mozilla-b2g/gaia/commit/ad7f2b548242fbe73036cfd8661cb450b42b7310
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
(Assignee)

Comment 13

2 years ago
Comment on attachment 8692359 [details] [review]
[gaia] steveck-chung:bug-1224497-dailer-emergency-call > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Emergency call wont work from calling in contact detail view, and no error dialog does not exist while calling other number without sim.
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Attachment #8692359 - Flags: approval-gaia-v2.5?
(In reply to Steve Chung [:steveck] from comment #13)
> [String changes made]: N/A

Sorry but that's not true. You're moving a string from one file to another, that's a string change (to be more precise, one removal, one addition).
Keywords: late-l10n
I was able to dial the emergency number after performing the repro steps on Flame 2.6 and Aries 2.6.

Environmental Variables:
Device: Aries 2.6 [Full Flash]
BuildID: 20151201122021
Gaia: 59c8605876736b22acaaed25be00008e452149cb
Gecko: 89ae375e24d7560f613b75a585e9ed4238604494
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: FlameKK 2.6 [Full Flash][512mb]
BuildID: 20151201030222
Gaia: 59c8605876736b22acaaed25be00008e452149cb
Gecko: 66a6d7ec9534b9d7847b665142fef0dd87623768
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
Emergency number could be called.
Status: RESOLVED → VERIFIED
status-b2g-master: fixed → verified
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
(Assignee)

Comment 16

2 years ago
(In reply to Francesco Lodolo [:flod] from comment #14)
> (In reply to Steve Chung [:steveck] from comment #13)
> > [String changes made]: N/A
> 
> Sorry but that's not true. You're moving a string from one file to another,
> that's a string change (to be more precise, one removal, one addition).

Ah you're right, sorry about the negligence.
Comment on attachment 8692359 [details] [review]
[gaia] steveck-chung:bug-1224497-dailer-emergency-call > mozilla-b2g:master

Limiting 2.5 only to TV patches. Also, this breaks string freeze. 

Foxfooders getting updates from master/b2g-ota branch. This patch is already there for foxfooders. Removing the uplift nomination.

Thank you
Attachment #8692359 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5-
You need to log in before you can comment on or make changes to this bug.