Silverlight plugin not rendering and refreshing correctly in FF 42

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: j.kitching, Unassigned)

Tracking

42 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

65.15 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
(Reporter)

Description

3 years ago
Created attachment 8687131 [details]
Bug_Details.docx

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

Steps to reproduce:

Go to https://preview.mumoffice.morgenundmorgen.de/
It's a German site but the test is very simple.
Enter Username: MozillaTest Password: MozillaTest
Click on "Anmelden"


Actual results:

In Firefox 42 it took over 30 seconds for a result to be displayed of the login attempt.


Expected results:

The result (a popup window) should have been displayed after about 3 seconds. Test with IE 11 for a comparison.

See attachment for more details.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 1

3 years ago
Is this a regression from previous versions of Firefox? NPAPI and Silverlight are considered legacy technologies and so it's unlikely that we would diagnose or fix this unless it's a regression in Firefox.
Flags: needinfo?(j.kitching)
If this were a W64 bug I'd say it's a dupe of bug 1187005. But the WOW64 string in the UA means "32-bit app running on a 64-bit OS" so I'm less sure.

Reporter: In the "Plugins" tab of your add-ons manager, is Silverlight set to "Always Activate" — or to something else?
Hardware: Unspecified → x86
(Reporter)

Comment 3

3 years ago
The previous versions of Firefox were working fine. This problem has just appeared with version 42. 

Silverlight is set to "Always Activate" in the "Plugins" tab of my add-ons manager.
Flags: needinfo?(j.kitching)
Comment hidden (off-topic)
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.