TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_downgraded.js (and v6|v11|v19|v24|v25|v26|v27)

RESOLVED DUPLICATE of bug 1232067

Status

RESOLVED DUPLICATE of bug 1232067
3 years ago
2 years ago

People

(Reporter: mkmelin, Unassigned)

Tracking

({intermittent-failure})

Trunk
Unspecified
Mac OS X
intermittent-failure

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_downgraded.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_v6.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_v11.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_v19.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_v24.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_v25.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_v26.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_v27.js | xpcshell return code: 0 


05:02:05     INFO -  TEST-START | toolkit/components/places/tests/migration/test_current_from_downgraded.js
05:02:06  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_downgraded.js | xpcshell return code: 0
05:02:06     INFO -  TEST-INFO took 377ms
05:02:06     INFO -  >>>>>>>
05:02:06     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
05:02:06     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
05:02:06     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
05:02:06     INFO -  running event loop
05:02:06     INFO -  toolkit/components/places/tests/migration/test_current_from_downgraded.js | Starting setup
05:02:06     INFO -  (xpcshell/head.js) | test setup pending (2)
05:02:06     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
05:02:06     INFO -  Unexpected exception Error: Error: couldn't find function symbol in library at resource://gre/modules/workers/require.js line 139 > Function:1042
05:02:06     INFO -  postMessage@resource://gre/modules/PromiseWorker.jsm:324:1
05:02:06     INFO -  this.BasePromiseWorker.prototype.post@resource://gre/modules/PromiseWorker.jsm:263:1
05:02:06     INFO -  post/<@resource://gre/modules/osfile/osfile_async_front.jsm:429:25
05:02:06     INFO -  Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:934:23
05:02:06     INFO -  this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813:7
05:02:06     INFO -  Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:744:11
05:02:06     INFO -  this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:776:7
05:02:06     INFO -  Promise.prototype.then@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:451:5
05:02:06     INFO -  this.Scheduler.push@resource://gre/modules/osfile/osfile_async_front.jsm:376:19
05:02:06     INFO -  post@resource://gre/modules/osfile/osfile_async_front.jsm:408:1
05:02:06     INFO -  getCurrentDirectory@resource://gre/modules/osfile/osfile_async_front.jsm:886:10
05:02:06     INFO -  setupPlacesDatabase<@/builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/migration/head_migration.js:31:26
05:02:06     INFO -  setup@/builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/migration/test_current_from_downgraded.js:5:9
05:02:06     INFO -  _run_next_test@/builds/slave/test/build/tests/xpcshell/head.js:1467:9
05:02:06     INFO -  do_execute_soon/<.run@/builds/slave/test/build/tests/xpcshell/head.js:659:9
05:02:06     INFO -  _do_main@/builds/slave/test/build/tests/xpcshell/head.js:208:5
05:02:06     INFO -  _execute_test@/builds/slave/test/build/tests/xpcshell/head.js:519:5
05:02:06     INFO -  @-e:1:1
05:02:06     INFO -  exiting test
05:02:06     INFO -  <<<<<<<

http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-macosx64/1447499202/comm-central_snowleopard_test-xpcshell-bm107-tests1-macosx-build14.txt.gz


http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/components/places/tests/migration/test_current_from_downgraded.js#5

---> something to do with with CURRENT_SCHEMA_VERSION ??? That constant is also found ONLY in the other failing test files.

Comment 1

3 years ago
These also pass locally on OSX.
OS: Unspecified → Mac OS X

Comment 2

3 years ago
(In reply to aleth [:aleth] from comment #1)
> These also pass locally on OSX.

In dev-apps-thunderbird mailing list there was a post by Philip Chee:
--- begin quote ---
>
> I suspect in Bug 1224846 that this could be a packager/deployment 
> problem just like the previous test failures that were only observed in 
> OS X Opt builds. Tests pass during OS X Debug builds and according to 
> comments in the bug reports the test pass locally as well. For me this 
> indicates that some files are not in place when the test runs. Now if 
> the error message would include the file or function that should be 
> loaded via require script.

Try adding some logging e.g.

https://hg.mozilla.org/mozilla-central/rev/f68d4b2ac619

Also:
https://developer.apple.com/library/mac/documentation/Darwin/Reference/ManPages/man3/getcwd.3.html

--- end quote ---
So maybe require.js can be enhanced to print out library name (?).
[If only we had more man-power...]

TIA

Updated

3 years ago
Depends on: 1232067
Summary: TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_(downgraded|v6|v11|v19|v24|v25|v26|v27).js → TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_downgraded.js (and v6|v11|v19|v24|v25|v26|v27)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1232067
You need to log in before you can comment on or make changes to this bug.