Can't use drop down menus in Firefox for Android

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Tobias K., Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(firefox42 affected, firefox43 affected, firefox44 unaffected, firefox45 unaffected, fennec42+)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Android 5.0.2; Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Build ID: 20151029024147

Steps to reproduce:

Open Webinterface of Facebook in Android Firefox OR open www.merkur.de. It's impossible to use dropdown menus. If you push on related website content, just nothing happens. With different browser Dolphin, it's no problem to open dropdown menus. My device: Samsung Galaxy A5 with Android 5.x.



Expected results:

Dropdown menu shall appear once you pushed related website content.

Updated

2 years ago
Component: Untriaged → General
Product: Core → Firefox for Android
Version: 42 Branch → Firefox 42
I can reproduce the issue on Moto X (Android 4.4) and Nexus 6 (Android 5.1.1) on Firefox for Android 43 Beta 6 and Firefox for Android 42.0.1. I cannot reproduce the issue on latest Aurora and Nightly.

Logs:

V/GeckoDynamicToolbarAnimator(6072): All fingers lifted, completing show
V/GeckoDynamicToolbarAnimator(6072): Requested toolbar animation to translation 0.0
V/GeckoDynamicToolbarAnimator(6072): Changing animation to immediate jump
V/GeckoBrowserApp(6072): On pan/zoom stopped, short page: false; atBottomOfLongPage: false
W/GeckoEventDispatcher(6072): No listeners for Gesture:clusteredLinksClicked
Status: UNCONFIRMED → NEW
status-firefox42: --- → affected
status-firefox43: --- → affected
status-firefox44: --- → unaffected
status-firefox45: --- → unaffected
Ever confirmed: true

Updated

2 years ago
tracking-fennec: --- → ?
Flags: needinfo?(snorp)
This appears to be caused by zoomed view being enabled and busted. The Gesture:clusteredLinksClicked message indicates that we are trying to open the zoomed view, which fails, and the click is then dropped[0].

Zoomed view isn't supposed to be enabled on release. It looks like it was inadvertently enabled by default for all branches in bug 1165128[1]. Margaret do you want to push a patch to flip that pref on release/beta or what?

[0] http://mxr.mozilla.org/mozilla-release/source/mobile/android/chrome/content/browser.js#5402
[1] https://hg.mozilla.org/releases/mozilla-release/rev/12df4e64ecc3
Flags: needinfo?(snorp) → needinfo?(margaret.leibovic)
Filed bug 1227974 for the accidental enabling of zoomed view

Updated

2 years ago
Depends on: 1227974
Margaret, is this fixed after bug 1227974?

Comment 5

2 years ago
(In reply to Michael Comella (:mcomella) from comment #4)
> Margaret, is this fixed after bug 1227974?

That patch just landed on beta and release. Teodora, can you verify that patch fixed this issue?
Flags: needinfo?(margaret.leibovic) → needinfo?(teodora.vermesan)
I cannot reproduce the issue anymore using Moto X (Android 4.4) on Firefox for Android 43 Beta 7
Flags: needinfo?(teodora.vermesan)

Comment 7

2 years ago
I'm going to close this, since it was fixed by bug 1227974.
Status: NEW → RESOLVED
tracking-fennec: ? → 42+
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.