Mac: Search bar missing in Bookmarks Manager

RESOLVED FIXED in seamonkey2.44

Status

SeaMonkey
Search
RESOLVED FIXED
2 years ago
11 months ago

People

(Reporter: promo, Assigned: Philip Chee)

Tracking

SeaMonkey 2.39 Branch
seamonkey2.44
All
Mac OS X

SeaMonkey Tracking Flags

(seamonkey2.44 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8687666 [details]
@ 2015-11-15 um 13.22.19.jpg

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:42.0) Gecko/20100101 Firefox/42.0 SeaMonkey/2.39
Build ID: 20151103192036

Steps to reproduce:

Search Button is missing in Bookmarks Manager Window


Actual results:

No way to search in Bookmarks Manager anymore

Comment 1

2 years ago
And what happens if you restart SeaMonkey in Safe Mode (or in particular, revert to the Default or Modern themes)?

http://kb.mozillazine.org/Safe_mode
(Reporter)

Comment 2

2 years ago
Safe mode, classic or modern theme... same thing!
(Reporter)

Comment 3

2 years ago
It did work in v2.3.8 though!

Comment 4

2 years ago
Are you using the -de version of SeaMonkey or otherwise have various locales installed?

Could be an L10n issue?
(Reporter)

Comment 5

2 years ago
I'm using the English US-Version... just one user profile!
(Reporter)

Comment 6

2 years ago
Just tried the -de version, doesn't work here either!

Comment 7

2 years ago
per reports @ http://forums.mozillazine.org/viewtopic.php?f=40&t=2973629 this is a Mac OS X specific issue
OS: Unspecified → Mac OS X
(Assignee)

Comment 8

2 years ago
Looks like fallout from Bug 1153577 - Users should be able to hide the menubar and show it with the ALT key.

CC Neil: I thought this was enabled only in Windows and Linux?
Blocks: 1153577
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(neil)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1226656
(In reply to Philip Chee from comment #8)
> Looks like fallout from Bug 1153577 - Users should be able to hide the
> menubar and show it with the ALT key.
> 
> CC Neil: I thought this was enabled only in Windows and Linux?

The problem is that the search box is positioned in the menu toolbar. When the toolbar was just a regular toolbar, then the menu was hidden on the Mac and just the search box showed. But because you made the toolbar a menu toolbar, the whole toolbar is now hidden on the Mac.

Probably the easiest solution is to overlay the type="menubar" attribute using the platform overlay.
Flags: needinfo?(neil)

Updated

2 years ago
Summary: Bookmarks Manager Search Button is missing in SeaMonkey 2.3.9 → Bookmarks Manager Search missing in Mac Menu Bar

Updated

2 years ago
Duplicate of this bug: 1232093

Comment 12

2 years ago
Work-around for users facing this issue: 
- open xulstore.json in your profile into a text editor.
- search for "placesToolbar"
- replace that entry with:
"placesToolbar":{"type":""}
- save the file and reopen SeaMonkey

This works by removing type=menubar which prevents SeaMonkey from hiding that toolbar in OSX.

Updated

a year ago
See Also: → bug 1153577

Updated

a year ago
Summary: Bookmarks Manager Search missing in Mac Menu Bar → Mac: Search bar missing in Bookmarks Manager
(Assignee)

Comment 13

a year ago
Created attachment 8724549 [details] [diff] [review]
Patch v1.0 remove autohide from the bookmarks toolbar for all platforms.

I thought removing the autohide for all platforms to be the least complicated way.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8724549 - Flags: review?(stefanh)

Updated

a year ago
Attachment #8724549 - Flags: review?(stefanh) → review+
(Assignee)

Comment 14

a year ago
http://hg.mozilla.org/comm-central/rev/f5b45f40af3e
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-seamonkey2.44: --- → fixed
Hardware: Unspecified → All
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.44
You need to log in before you can comment on or make changes to this bug.