Closed Bug 1224982 Opened 7 years ago Closed 7 years ago

Stop video playing and release its decoder when the tap is in the background.

Categories

(Core :: Audio/Video: Playback, defect)

37 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1224973

People

(Reporter: bwu, Unassigned)

Details

It would be better to stop video playing and release its decoder when the tap is in the background and audio part continue being played. That should be able to save some power which is important on laptops. Once that tap is going back to foreground, recreate decoder and resume the video playing.
Don't we have dormant mode for that?
There's already two bugs now for this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1174419
(In reply to JW Wang [:jwwang] from comment #1)
> Don't we have dormant mode for that?

dormant only works for paused video. The idea is to continuing "playing" the video, but as the video isn't shown we can simply skip the video decoding part
Resolution: DUPLICATE → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1174419
You need to log in before you can comment on or make changes to this bug.