Disable Intel VPx hardware decoder

RESOLVED FIXED in Firefox 44

Status

()

P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: cpeterson, Assigned: jya)

Tracking

(Blocks: 1 bug)

unspecified
mozilla45
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 unaffected, firefox43 unaffected, firefox44+ fixed, firefox45+ fixed, b2g-v2.5 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
The Intel VPx hardware decoder has some buggy drivers and can actually be slower than the ffvp9 software decoder.
(Reporter)

Comment 1

3 years ago
[Tracking Requested - why for this release]:

We should disable Intel VPx hardware decoder (enabled in bug 1101885) in FF 44 because it can cause crashes.
Blocks: 1101885
tracking-firefox44: --- → ?
tracking-firefox45: --- → ?
No longer depends on: 1101885
Priority: -- → P1
(Assignee)

Comment 2

3 years ago
Created attachment 8690596 [details] [diff] [review]
Disable intel hardware VP decoder by default.
Attachment #8690596 - Flags: review?(cpeterson)
(Reporter)

Comment 3

3 years ago
Comment on attachment 8690596 [details] [diff] [review]
Disable intel hardware VP decoder by default.

Review of attachment 8690596 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. We will need to uplift this fix to Aurora 44.

::: modules/libpref/init/all.js
@@ +341,5 @@
>  pref("media.opus.enabled", true);
>  #ifdef MOZ_WAVE
>  pref("media.wave.enabled", true);
>  #endif
>  #ifdef MOZ_WEBM

btw, why do we need #ifdef MOZ_WEBM? Do we ever build Firefox without WebM support?
Attachment #8690596 - Flags: review?(cpeterson) → review+
(Assignee)

Comment 4

3 years ago
I think that this is now unused.

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/87c224b71033
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox45: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
(Reporter)

Updated

3 years ago
Blocks: 1215405
Jean-yves, should we consider uplifting this to Aurora44?
Flags: needinfo?(jyavenard)
Tracked as disabling this will improve FF44 stability.
tracking-firefox44: ? → +
(Assignee)

Comment 9

3 years ago
yes it should be.
Flags: needinfo?(jyavenard)
(Assignee)

Comment 10

3 years ago
Comment on attachment 8690596 [details] [diff] [review]
Disable intel hardware VP decoder by default.

Approval Request Comment
[Feature/regressing bug #]:1225019
[User impact if declined]: Computers needing reboot, decoding error
[Describe test coverage new/current, TreeHerder]: In central, there can't be regressions caused by the commit, it's just disabling a new code.
[Risks and why]: None
[String/UUID change made/needed]: None
Attachment #8690596 - Flags: approval-mozilla-aurora?
Comment on attachment 8690596 [details] [diff] [review]
Disable intel hardware VP decoder by default.

It seems to be me this decoder is not ready to be used by default and therefore being pref'd off for 44. Taking it.
Attachment #8690596 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 12

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/b17fbacc5377
status-firefox44: affected → fixed
tracking-firefox45: ? → +
You need to log in before you can comment on or make changes to this bug.