Closed Bug 1225054 Opened 6 years ago Closed 6 years ago

In room list, if a room name is too long and requires "...", the "..." renders over the menu items of the pen menu

Categories

(Hello (Loop) :: Client, defect, P2)

defect

Tracking

(firefox45 fixed)

RESOLVED FIXED
mozilla45
Tracking Status
firefox45 --- fixed

People

(Reporter: RT, Assigned: mancas)

References

Details

Attachments

(3 files)

No description provided.
Snapshot of the issue
Blocks: 1209713
Rank: 21
Priority: -- → P2
Assignee: nobody → b.mcb
Status: NEW → ASSIGNED
Mike, can you review the patch? it should be quick. I've just added a css rule =)

Thanks!
Attachment #8687932 - Flags: review?(mdeboer)
Attached image ellipsis.png
Attachment #8687933 - Flags: ui-review?(b.pmm)
Attachment #8687933 - Flags: ui-review?(b.pmm) → ui-review+
(In reply to Manuel Casas Barrado [:mancas] from comment #2)
> Mike, can you review the patch? it should be quick. I've just added a css
> rule =)
> 
> Thanks!

Sure, but what's the cause of the ellipsis showing on top of the dropdown?
Flags: needinfo?(b.mcb)
If we don't set a z-index, the default value for the rule will be "auto", and according to the w3c:

The stack level of the generated box in the current stacking context is 0. The box does not establish a new stacking context unless it is the root element. [1]

So the ellipsis is in the same stack level.

[1] http://www.w3.org/TR/CSS2/visuren.html#z-index
Flags: needinfo?(b.mcb) → needinfo?(mdeboer)
I understand how z-index works :-) No, what I meant was that I don't understand that the absolutely positioned element (dropdown) would render on top of the text, except for the ellipsis which is there because of `text-overflow: ellipsis`. This must be a platform issue.
Flags: needinfo?(mdeboer)
Comment on attachment 8687932 [details] [diff] [review]
In room list, if a room name is too long and requires "...", the "..." renders over the menu items of the pen menu.

Review of attachment 8687932 [details] [diff] [review]:
-----------------------------------------------------------------

Seems like this work around is necessary! Thanks, Manu.
Attachment #8687932 - Flags: review?(mdeboer) → review+
Ah! Maybe you're right and this is a platform issue, because the ellipsis is generated and rendered by the browser =)
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/055104774f5d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
You need to log in before you can comment on or make changes to this bug.