Closed Bug 1225059 Opened 7 years ago Closed 5 years ago

[FTE] FTE Video Flash

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.5 affected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.5 --- affected
b2g-master --- affected

People

(Reporter: epang, Assigned: sfoster)

References

()

Details

(Keywords: regression, Whiteboard: [systemsfe])

There's a flash at the end of each fte video before it loops.  (tested on Aries)
This does not reproduce on the Flame, using GAIA_DPPX=1.5. On aries using GAIA_DPPX=2 (which should be correct for this device), this manifests as a slight shrinking/pulsing as the video loops. If you flash gaia with GAIA_DPPX=1 it is more like a brief flash or flicker as the video loops. 

For reference, we have the <video> element set up like so: 

<video src="/style/images/tutorial/Homescreen.mp4" id="tutorial-step-video" class="step-video-base" role="presentation" autoplay="" loop=""></video>

The video element has height: 100%; and its container gets scaled via flex-box. Computed width/height is therefore variable, but for example: 256.667×385px.
Added youtube link: https://youtu.be/PgneRVo_ApU
Aries device on left (DPPX=1, but is same result with DPPX=2) and Flame on right (represents the expected result)
:kats if this isn't your domain could you forward it? I'm not clear where in the stack this issue originates or who could provide a solution. I do know that fact that it doesnt reproduce on the Flame means it is unlikely to be a front-end/Gaia-side problem.
Flags: needinfo?(bugmail.mozilla)
Hm, it's hard to say what's causing that. If it's happening on Aries but not Flame it may be specific to device drivers or hardware. Sotaro, do you know what might be going on here?
Flags: needinfo?(bugmail.mozilla) → needinfo?(sotaro.ikeda.g)
Also if this is a regression getting a regression window would help.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #5)
> Also if this is a regression getting a regression window would help.

I don't know if this has always been there for the aries. It was only noticed during UX review of the updated tutorial videos, but I assume it also reproduces with the older assets so a regression window might be possible. Sotaro, I know we fixed various bugs for the aries earlier this year, so it wouldn't be useful to go back too far attempting to reproduce this. Can you identify a known-good build to start a window from that wouldn't conflate this issue with others?
Keywords: qawanted
cancelling qawanted for now, lets narrow down the search space a bit before requesting a window
Keywords: qawanted
(In reply to Sam Foster [:sfoster] from comment #6)
> (In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #5)
> > Also if this is a regression getting a regression window would help.
> 
> I don't know if this has always been there for the aries. It was only
> noticed during UX review of the updated tutorial videos, but I assume it
> also reproduces with the older assets so a regression window might be
> possible. Sotaro, I know we fixed various bugs for the aries earlier this
> year, so it wouldn't be useful to go back too far attempting to reproduce
> this. Can you identify a known-good build to start a window from that
> wouldn't conflate this issue with others?

I am not sure about the known build, but on 2015-07-22, I fixed last aries' hwc bug. arie's hwc bugs are gathered to bug 1173213. There is one open bug in bug 1173213, it is not related to arie's hwc.
Flags: needinfo?(sotaro.ikeda.g)
(In reply to Sotaro Ikeda [:sotaro] from comment #8)
> I am not sure about the known build, but on 2015-07-22, I fixed last aries'
> hwc bug. arie's hwc bugs are gathered to bug 1173213. There is one open bug
> in bug 1173213, it is not related to arie's hwc.

To prevent the already fixed bug, we need to flash whole rom or disable hwc.
QA: can you help confirm if this is a recent regression? Earliest build should be from/after 2015-07-22 (see comment #9)
Keywords: qawanted
Aries pixels per px should be 2.25, and Flame's should be 1.5. Regardless, I can repro this on Aries 2.6 and not on Flame 2.6. Symptom is the same as video shown at comment 2 where the video appears to shrink/pulsate at the beginning while looping. (I also noticed status bar icons flashing for several seconds)

I don't fully understand what the qawanted is for. I assume you wanted us to check a build BEFORE 7/22 and see if the bug repro's?

Bug reproduces on:
Device: Aries 2.6 Master
BuildID: 20151124121635
Gaia: e63c07af8cc636b9ffac2c20f9b8ad7e7fe2b977
Gecko: 45273bbed8efaface6f5ec56d984cb9faf4fbb6a
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
Flags: needinfo?(sfoster)
(In reply to Pi Wei Cheng [:piwei] from comment #11)
> Aries pixels per px should be 2.25, and Flame's should be 1.5. 

Oh really? window.devicePixelRatio reports '2' on the aries so this is news to me. Is that meaningful I wonder?

> Regardless, I
> can repro this on Aries 2.6 and not on Flame 2.6. Symptom is the same as
> video shown at comment 2 where the video appears to shrink/pulsate at the
> beginning while looping. (I also noticed status bar icons flashing for
> several seconds)
> 
> I don't fully understand what the qawanted is for. I assume you wanted us to
> check a build BEFORE 7/22 and see if the bug repro's?

No, builds AFTER 7/22. Due to other issues that were fixed before 7/22 we wont get meaningful results testing aries build before then.
Flags: needinfo?(sfoster)
I was told by Naoki that Aries should do GAIA_DEV_PIXELS_PER_PX=2.25 when making gaia, and Flame is 1.5. I'll ask Naoki next time because I'm curious as well.

Thanks for explaining. I tested an Aries build on 7/24 and issue does NOT occur. No visual anomalies when looping tutorial videos. Please add regression-window wanted tag if a window is needed.

No repro on:
Device: Aries 2.5 Master
BuildID: 20150724224008
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: 706318c7d595
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

----

Also went ahead and branch checked. This issue is reproducible on Aries 2.5.

Device: Aries 2.5
BuildID: 20151124191030
Gaia: 7726bfd621d709fa2d179704a44aebc1c309c296
Gecko: 124375497b14260515e8d2af9c8507a9995b7a47
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawantedregression
> Thanks for explaining. I tested an Aries build on 7/24 and issue does NOT
> occur. No visual anomalies when looping tutorial videos. Please add
> regression-window wanted tag if a window is needed.

Great, thanks for confirming that. Yes lets get a window here in that case. We're looking for a regression between BuildID: 20150724224008 and BuildID: 20151124191030
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Contact: pcheng
mozilla-inbound regression window:

Device: Aries
BuildID: 20151102103307
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: 053d95766084444de142f0fce166024f464f16ba
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Aries
BuildID: 20151102104628
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: 628b84e68ac708e33010a9b22e5a680010c230d3
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=053d95766084444de142f0fce166024f464f16ba&tochange=628b84e68ac708e33010a9b22e5a680010c230d3

This issue is caused by changes made in Bug 1199809.
Blocks: 1199809
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
John this issue seems to have been caused by the changes for bug 1199809.  Can you please take a look?
Flags: needinfo?(jmercado) → needinfo?(jolin)
I am going to check if Bug 1227415 mitigate the problem.
(In reply to Sotaro Ikeda [:sotaro] from comment #17)
> I am going to check if Bug 1227415 mitigate the problem.

After Bug 1227415, the symptom seems to becomes better than before. I did not sees video size change. But during seeking, color of top of the video seemed a bit strange.
(In reply to Sotaro Ikeda [:sotaro] from comment #18)
> (In reply to Sotaro Ikeda [:sotaro] from comment #17)
> > I am going to check if Bug 1227415 mitigate the problem.
> 
> After Bug 1227415, the symptom seems to becomes better than before. I did
> not sees video size change. But during seeking, color of top of the video
> seemed a bit strange.

 It could be the Venus->YV12 copying code causes the color problem. If I use Venus buffer for destination it looks fine.
 I also noticed that 1st tutorial video (Homescreen.mp4) occasionally flashes after seeking back to the beginning. Checking if the output buffers are in correct order now.
Flags: needinfo?(jolin)
patch in Bug 1219210 fixes the problem.
(In reply to John Lin [:jolin][:jhlin] from comment #19)
>  I also noticed that 1st tutorial video (Homescreen.mp4) occasionally
> flashes after seeking back to the beginning. Checking if the output buffers
> are in correct order now.

 The output order is correct after all. I tried making a copy of buffer of the last frame rather than sending the original one, and the symptom went away. Looks like the patch in bug 1199809 (attachment 8681800 [details] [diff] [review]) doesn't fully fix the issue that decoder uses buffer for output before/while it's displayed on screen.
Duplicate of this bug: 1230903
While b2g may live on, FTU will not
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.