Closed Bug 1225062 Opened 6 years ago Closed 6 years ago

[TV] FTE loses focus on mulet after adjusting development panel

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rexboy, Unassigned)

References

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(1 file)

STR:
1. Use mulet to run TV build.
2. Wait until Home FTE appear.
3. Adjust view size and development panel size
4. Focus back to the Home app (By clicking)

Expected:
The OK button gets its focus back and we can press enter to close FTE screen.

Actual:
Get Javascript Error.
The problem is that we didn't handle the case when focus get out of the FTE container, like dropping back to body element.

This doesn't happen on real TV environment. But for convenience on development, it's better to get rid of this problem.
A quick fix for this is to force FTE focus again on each mouse click. Let's try it.
Comment on attachment 8687866 [details] [review]
[gaia] rexboy7:1225062-fte-focus-on-click > mozilla-b2g:master

Hi Evelyn:
Can you take a look on this quick fix? Thanks!
Attachment #8687866 - Flags: review?(ehung)
Flags: needinfo?(ehung)
feature-b2g: --- → 2.5+
@Josh, it's not a 2.5 blocker, just a polish for dev tool.
feature-b2g: 2.5+ → ---
Flags: needinfo?(ehung)
Whiteboard: [ft:conndevices][partner-blocker][partner-cherry-pick] → [ft:conndevices]
Comment on attachment 8687866 [details] [review]
[gaia] rexboy7:1225062-fte-focus-on-click > mozilla-b2g:master

The patch looks good but I didn't try it. Did you test it on Mulet?
Attachment #8687866 - Flags: review?(ehung) → review+
Yeah I've tested it once, seems it works well.
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
master
https://github.com/mozilla-b2g/gaia/commit/bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.