Closed Bug 1225099 Opened 7 years ago Closed 7 years ago

User still displayed as logged-in after a disconnect action is performed

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox44 unaffected, firefox45 affected, fennec45+)

RESOLVED DUPLICATE of bug 1224708
Tracking Status
firefox44 --- unaffected
firefox45 --- affected
fennec 45+ ---

People

(Reporter: u549602, Unassigned)

References

Details

Environment: Nightly 
Device: XIaomi Mi i4 (Android 5.0.2);
Build: Nightly 45.0a1 11-15-2015;

Steps to reproduce:
1. Log in with a valid account
2. Go to Sync menu page and tap on Disconnect

Expected result:
User is disconnected and redirected to the settings menu, the Sign in Button is displayed. 

Actual result:
User is redirected to the settings menu but it is still displayed as logged in.

Note: If the user's account is tapped, he is redirected to the login page 
For further details please check: https://www.youtube.com/watch?v=smS6JTO8J-A&feature=youtu.be
Vivek, do we need to listen for account changes in SyncPreference?
Blocks: 1189356
Flags: needinfo?(vivekb.balakrishnan)
tracking-fennec: --- → ?
Currently we don't. But I am changing this behavior to load the account details async using Loaders in bug 1224708. This will be fixed as part of that bug.
Flags: needinfo?(vivekb.balakrishnan)
Depends on: 1224708
OK, please let me know if anything here or in bug 1224708 needs uplift to beta.
tracking-fennec: ? → 45+
(In reply to Vivek Balakrishnan[:vivek] from comment #2)
> Currently we don't. But I am changing this behavior to load the account
> details async using Loaders in bug 1224708. This will be fixed as part of
> that bug.

Was this fixed as part of bug 1224708? Can we close this bug?
Flags: needinfo?(vivekb.balakrishnan)
Flags: needinfo?(nalexander)
Yes, this bug can be closed. It was fixed as part of bug 1224708
Flags: needinfo?(vivekb.balakrishnan)
Flags: needinfo?(nalexander)
(In reply to Vivek Balakrishnan[:vivek] from comment #5)
> Yes, this bug can be closed. It was fixed as part of bug 1224708

Great, thanks!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224708
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.