Tabbed browsing: target="_blank" always opens separate window

VERIFIED DUPLICATE of bug 105547

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 105547
16 years ago
13 years ago

People

(Reporter: mozilla, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
At first I thought this was a bug in tabbed browsing, specifically "Windows
opened by Web page", but that checkbox may actually refer solely to pop-ups and
what I am describing now may be an unimplemented feature:

If a web page contains a URL w/ a target="_blank", it opens a separate browser
window instead of a separate tab, even if you have checked every single checkbox
under the Tabbed Browsing preferences. The preferred behavior would be for the
browser to open another tab. See the URL above, which includes a number of such
links. Ideally, you could click on five to ten of your favorite sites and have
them load into new tabs. Not only would this consume significantly less
resources but also the focus wouldn't shift from the page the user is currently
reading.

Several other points regarding the tabbed browsing preferences page, all of
which go to the idea of simplifying the user experience:

* under preferences (and perhaps as part of a setup wizard), the user should
select tabbed or regular browsing. If tabbed, then the only really important
option listed is whether to open a new tab when entering in a URL (v. reusing
the current tab). The rest of options relating, essentially, to the focus or to
a mixture of tabbed and multiple window browsing paradigms needlessly confuse
novices, IMO.

* Many times, I have inadvertently had 5-10 tabs open and mistakenly closed all
of them (by closing the browser as opposed to the active tab) by selecting the
program close icon [X] in the upper right hand corner. If the user has selected
tabbed browsing as the default, I would add a dialog box that only appears when
multiple tabs are present to prevent this 'operator error'. I suggest that the
dialog box be enabled by default and contain two choices: [] "Close active tab"
[] "Close browser" and a control [] "Always close browser without asking me
first." The user could reenable the dialog box from the preferences panel.
Compare the SSL warnings dialog boxes.

* if the user has selected tabbed browsing as the default, then the first menu
item under the File menu should be new Navigator tab (as opposed to a new
Navigator window). Or less confusing for the user and less brand conscious, "New
browser tab."

* tabs should inherit the text color/background color of the displayed web page.
Because color is important to the user's cognitive processes, it would speed the
ability of the user to switch between pages (because the user doesn't have to
read the name of the tab).
Please file one bug per issue?  That makes it much easier to spread the
development work...

The main issue here is a duplicate of "Windows open in new window instead of
tabs (target=<nonexsistant_frame>)"

*** This bug has been marked as a duplicate of 105547 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
vrfy summary is a duplicate and reporting multiple issues in a single bug is 
not recommended.

i have not seen a request for *4, please file a new bug for it in the UID 
component. (I'm not sure i agree, but i think it's worth considering)

i'm opposed to *3, but we already have more than enough bugs about file>new* so 
we don't need more, if you like you can start a thread in npm.xpfe or somewhere 
(see http://www.mozilla.org/community.html )

i have not seen a request for *2, but it is like a bug we have about file>quit 
not providing a yes/no dialog, but more complicated.  since file>quit has no 
dialog i very much doubt you can get a dialog for *2. Feel free to file a bug 
in UID (as with *4)

i'm opposed to *1 and request that you discuss this in a npm.xpfe or similar as 
with *3
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.