Error: TypeError: feedWindow.mView.treeBox is null

RESOLVED FIXED in Thunderbird 45.0

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: WaltS48, Assigned: alta88)

Tracking

({regression})

45 Branch
Thunderbird 45.0
x86_64
Linux
regression

Thunderbird Tracking Flags

(thunderbird42 wontfix, thunderbird43 fixed, thunderbird44 fixed, thunderbird45 fixed, thunderbird_esr38 affected)

Details

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8687974 [details]
after_adding_feed.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151112144305

Steps to reproduce:

Created a Blogs and News Feeds account in Daily 45.0a1
Added a news feed to Daily.
Went to add another  news feed and the Feed Subscription window was blank.


Actual results:

Went to add another  news feed and the Feed Subscription window was blank

Planet Mozilla feeds appear to make the whole UI go blank.

Error Console shows:

Error: TypeError: feedWindow.mView.treeBox is null
Source File: chrome://messenger-newsblog/content/feed-subscriptions.js
Line: 1865


Expected results:

Should be able to add news feeds without it causing issues with the UI like the attached screen shot.
(Reporter)

Comment 1

2 years ago
Created attachment 8687975 [details]
feed_subscriptions.png
(Reporter)

Comment 2

2 years ago
Created attachment 8687976 [details]
error_console.png
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Assignee)

Comment 3

2 years ago
this is because closing the subscriptions window using the Close button doesn't clean up properly, unlike if you close it using the titlebar button.  there is a trivial fix in the patch for bug 1219084.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

2 years ago
Keywords: regression
(Assignee)

Comment 4

2 years ago
Created attachment 8693224 [details] [diff] [review]
close.patch

move patch here.
Assignee: nobody → alta88
Attachment #8693224 - Flags: review?(mkmelin+mozilla)

Comment 5

2 years ago
Comment on attachment 8693224 [details] [diff] [review]
close.patch

Review of attachment 8693224 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #8693224 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 6

2 years ago
https://hg.mozilla.org/comm-central/rev/26610a75105c91f9dca6e14fb2ff97b0d7c8830c
Bug 1225165 - Clean up properly when closing the subscriptions window using the Close button. r=mkmelin

Comment 7

2 years ago
Is it known which bug caused this regression? Does it need uplift?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 45.0
(Assignee)

Comment 8

2 years ago
Comment on attachment 8693224 [details] [diff] [review]
close.patch

The button was added in bug 368266, Tb29.  Not so much a regression as a failure to realize window.close() does/did not cause the window's onclose handler to run. The sequence to hit this is likely rather uncommon, but the patch is very low risk.
Attachment #8693224 - Flags: approval-comm-esr38?

Updated

2 years ago
Depends on: 1229404

Updated

2 years ago
status-thunderbird42: --- → wontfix
status-thunderbird43: --- → fixed
status-thunderbird44: --- → fixed
status-thunderbird45: --- → fixed
status-thunderbird_esr38: --- → affected

Updated

2 years ago
Attachment #8693224 - Flags: approval-comm-esr38?
You need to log in before you can comment on or make changes to this bug.