Status bar icons change color before homescreen transition when home button is pressed

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::System::Status bar, Utility tray, Notification
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: AdamA, Assigned: jedireza)

Tracking

({polish, regression})

unspecified
2.6 S2 - 12/4
ARM
Gonk (Firefox OS)
polish, regression

Firefox Tracking Flags

(b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing][Spark][systemsfe], URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8688161 [details]
logcat

Description:
When the user is in an app that makes the status bar icons change from their default color pressing home will make the status bar icons change to white as soon as the button is pressed instead of after the transition to the home screen.

Repro Steps:
1) Update a Aries to 20151116140807
2) Open settings
3) Press home button
4) Observe status bar icons as app transitions

Actual:
The status bar icons change color as soon as the button is pressed

Expected:
It is expected that the status bar icons change color after the transition to the homescreen

Environmental Variables:
Device: Aries 2.6 [Full Flash]
Build ID: 20151116140807
Gaia: e8c15ae4e5324a210000ee0a869a962aa542009f
Gecko: 4294bf91174b71ed7440dc491dac5d15394ec227
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
See attached: video clip, logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.6.

Environmental Variables:
Device: Flame 2.6 [Full Flash][512mb]
BuildID: 20151116030435
Gaia: e8c15ae4e5324a210000ee0a869a962aa542009f
Gecko: 48d636f678b0e5162ab868dc9024a5ffe350460c
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
The status bar icons change color as soon as the button is pressed
----------------------------
This issue DOES NOT occur on Flame 2.5.

Environmental Variables:
Device: Aries 2.5 [Full Flash]
BuildID: 20151112123156
Gaia: 240088d7a70dae41215ef61dd3fe3487709a4b65
Gecko: e1f0fe73bc84ad2103a5c661bdd15c16a47d4af5
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
The status bar icons change color after transitioning to homescreen.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Minor issue, not nominatig to block.  Alison can I get your opinion as well though?

Either way let's get a window here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted

Updated

3 years ago
QA Contact: jthomas
Keywords: polish
Whiteboard: [2.6-Daily-Testing][Spark] → [2.6-Daily-Testing][Spark][systemsfe]

Comment 3

3 years ago
Caused by changes made in Bug 1200043

B2G Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.6
BuildID: 20151105115832
Gaia: 65973b65c648691ce4da0e5fe913235260fe3c5e
Gecko: 6633c7d8f3dc0cf70e176b7542b0c68ed522c66e
Version: 45.0a1 (2.6)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Environmental Variables:
Device: Flame 2.6
BuildID: 20151105123334
Gaia: 5c5717f893162f56baa578bf5b6b90cdaf0ff6fd
Gecko: 9945e6564ded038566b0742f74810aaf34797dbf
Version: 45.0a1 (2.6)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Last Working gaia / First Broken gecko - This issue does NOT occur with broken Gecko
Gaia: 65973b65c648691ce4da0e5fe913235260fe3c5e
Gecko: 9945e6564ded038566b0742f74810aaf34797dbf

Last Working gecko / First Broken gaia - This issue DOES occur with broken Gaia
Gecko: 6633c7d8f3dc0cf70e176b7542b0c68ed522c66e
Gaia: 5c5717f893162f56baa578bf5b6b90cdaf0ff6fd

Gaia Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/65973b65c648691ce4da0e5fe913235260fe3c5e...5c5717f893162f56baa578bf5b6b90cdaf0ff6fd
Blocks: 1200043
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Reza the changes for bug 1200043 seem to have caused this issue.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(rakhavan)
(Assignee)

Comment 5

3 years ago
Confirmed. I'm working on a fix for this.
Assignee: nobody → rakhavan
Status: NEW → ASSIGNED
Flags: needinfo?(rakhavan)
Target Milestone: --- → 2.6 S1 - 11/20
Created attachment 8689303 [details] [review]
[gaia] jedireza:home-button-closes-update-manager-dialogs > mozilla-b2g:master
(Assignee)

Comment 7

3 years ago
My PR fixes the case where:
 - the app chrome is lightly colored
 - AND an UpdateManager dialog _is not_ showing
 - AND then you press the home button

Now the status bar icons no longer change color before the transition happens.

- - - -

However, in the cases where:
 - the app chrome is lightly colored
 - AND an UpdateManager dialog _is_ showing
 - AND then you press the home button

Then you will see the dialog disappear + the the icons change color and then (with incorrect icon colors) the app will transition to the home screen.

The root cause in these cases is probably related to bug 1082521 and bug 1210453.

- - - -

Technical note:

An easy way to show one of these dialogs is to use WebIDE to debug the system app, open the console and execute one of these functions:

 - UpdateManager.showPromptWifiPrioritized()
 - UpdateManager.showPromptNoConnection()
 - UpdateManager.showForbiddenDownload()
 - UpdateManager.showDownloadPrompt()

Then you can press the home button to observe the behavior.

I'm still waiting for treeherder results. I'll post again when they're all green.
(Assignee)

Comment 8

3 years ago
Comment on attachment 8689303 [details] [review]
[gaia] jedireza:home-button-closes-update-manager-dialogs > mozilla-b2g:master

Gij 22 has a couple failing assertions [1] but they seem unrelated to the changes I made. When I run the same test locally my results vary, 2/5 failures, then 4/5 fail then back to 2/5 failing.

I pinged Fred on GitHub for a review of an assertion I removed in my PR. But I'd like to move forward on getting a review and hope the tests clear up next time I rebase.

[1] https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=189537063adca3f66705cc9ba9b3afb194daad65
Flags: needinfo?(gasolin)
Attachment #8689303 - Flags: review?(etienne)
Comment on attachment 8689303 [details] [review]
[gaia] jedireza:home-button-closes-update-manager-dialogs > mozilla-b2g:master

r=me with a test showing that |Service.request.calledWith('hideCustomDialog')| is false after home/holdhome when we don't show a dialog before.
Attachment #8689303 - Flags: review?(etienne) → review+

Comment 10

3 years ago
looks good, thanks
Flags: needinfo?(gasolin)
(Assignee)

Updated

3 years ago
Target Milestone: 2.6 S1 - 11/20 → 2.6 S2 - 12/4
(Assignee)

Comment 11

3 years ago
Comment on attachment 8689303 [details] [review]
[gaia] jedireza:home-button-closes-update-manager-dialogs > mozilla-b2g:master

Etienne, thanks for the last review. The PR is updated. I've added the tests you mentioned.
Attachment #8689303 - Flags: review+ → review?(etienne)
Comment on attachment 8689303 [details] [review]
[gaia] jedireza:home-button-closes-update-manager-dialogs > mozilla-b2g:master

Thanks!
Attachment #8689303 - Flags: review?(etienne) → review+
(Assignee)

Comment 13

3 years ago
On master: https://github.com/mozilla-b2g/gaia/commit/64aba1a65219ca906ccba27a6b762612dcec1fc6
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Created attachment 8694582 [details]
Verified_Flame_master.3gp

This bug has been verified as pass on latest build of Flame KK master 512mb and Aries KK master by the STR in comment 0.
Actual results: The status bar icons change color after the transition to the homescreen.
See attachment: verified_Flame_master.3gp
Reproduce rate:0/10

Device: Flame KK master 512mb (pass)
Build ID               20151201150223
Gaia Revision          59c8605876736b22acaaed25be00008e452149cb
Gaia Date              2015-12-01 02:58:37
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1003fca97839fdfbfefb89c48c9e05a940bc9fb9
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151201.183010
Firmware Date          Tue Dec  1 18:30:23 EST 2015
Firmware Version         V18D V4
Bootloader             L1TC000118D0

Device: Aries KK master (pass)
Build ID               20151202015416
Gaia Revision          7847a3c1b28e039631509978518b36fd3c5f9585
Gaia Date              2015-12-01 18:47:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/470f4f8c2b2d6f82e56e161a4b05262c85f55b59
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151202.011126
Firmware Date          Wed Dec  2 01:11:35 UTC 2015
Bootloader             s1
QA Whiteboard: [QAnalyst-Triage+] → [MGSEI-Triage+]
status-b2g-master: affected → verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.