Closed Bug 1225395 Opened 4 years ago Closed 4 years ago

MapIterator and SetIterator have a non-spec IteratorIdentity on their prototypes

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1225396
Tracking Status
firefox45 --- affected

People

(Reporter: bzbarsky, Unassigned)

References

Details

I don't see why it needs to be there, since it's on %IteratorPrototype% anyway...
Flags: needinfo?(efaustbmo)
Ah, looks like the thing on %IteratorPrototype% is something weird: it doesn't actually have IteratorIdentity as its Symbol.iterator.  :(
Depends on: 1201089
Patches in bug 1225396 get rid of this.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(efaustbmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1225396
You need to log in before you can comment on or make changes to this bug.