Playing Vimeo video embed on medium.com causes Nexus 6P phone to lock up or restart/reboot

RESOLVED DUPLICATE of bug 1221228

Status

()

Firefox for Android
Audio/Video
--
critical
RESOLVED DUPLICATE of bug 1221228
3 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({crash, hang})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Using the latest Firefox for Android beta release from Google Play (v43.0b2), on a Google Nexus 6P running Android 6.0.

1) Open https://medium.com/backchannel/pac-man-s-siren-call-4b589ea1d1e#873e
2) Check the video with thumbnail of a Windows XP desktop is showing (it has a caption beneath it that says "It’s the siren of an invisible Pac-Man game...")
3) Tap the video

Expected:
Video plays - or even if it doesn't, the browser remains responsive and the phone does not restart.

Actual:
The first time...
* The phone wouldn't respond to me pressing volume up whilst the video was loading
* The screen then went entirely black
* The Google boot logo appeared and the phone went through a normal boot up sequence

The next time...
* The screen froze (image remained the same, touching the screen had no effect) rather than going black
* I had to long press the power button to force restart the phone


Note: Using Chrome on the phone, the issue does not reproduce.

The original markup in question:

<figure name="873e" id="873e" class="graf--figure graf--iframe graf-after--p"><div class="iframeContainer"><iframe data-width="960" data-height="720" width="700" height="525" src="/media/69ace0764b78fe8fc4d9657114c38e09?maxWidth=700" data-media-id="69ace0764b78fe8fc4d9657114c38e09" frameborder="0"></iframe></div></figure>

This iframe then contains another iframe:

<iframe src="https://cdn.embedly.com/widgets/media.html?src=https%3A%2F%2Fplayer.vimeo.com%2Fvideo%2F143556154&amp;url=https%3A%2F%2Fvimeo.com%2F143556154&amp;image=http%3A%2F%2Fi.vimeocdn.com%2Fvideo%2F541167789_960.jpg&amp;key=d04bfffea46d4aeda930ec88cc64b87c&amp;type=text%2Fhtml&amp;schema=vimeo" scrolling="no" width="700" frameborder="0" height="525"></iframe>

Which contains another iframe:

<iframe allowfullscreen="true" src="https://player.vimeo.com/video/143556154?referrer=https%3A%2F%2Fmedium.com%2Fmedia%2F69ace0764b78fe8fc4d9657114c38e09%3FmaxWidth%3D700" id="player" scrolling="no" frameborder="0"></iframe>
(Reporter)

Comment 1

3 years ago
It seems as though others are seeing this with the Nexus 6P and Firefox for Android too:
https://productforums.google.com/forum/#!topic/nexus/T_CN5jSnQsc

(Sigh, I wish people would file bugs)
(Reporter)

Updated

3 years ago
Summary: Playing Vimeo video embed on medium.com causes Nexus 6P phone to lock up or restart → Playing Vimeo video embed on medium.com causes Nexus 6P phone to lock up or restart/reboot
(Reporter)

Updated

3 years ago
Flags: needinfo?(snorp)
(Reporter)

Comment 3

3 years ago
Visiting https://player.vimeo.com/video/143556154 directly in Firefox for Android doesn't reproduce.
Duplicate of bug 1221228?
(Reporter)

Comment 5

3 years ago
Ah yes. It's only fixed on Nightly at the moment.
I'd searched closed bugs too, but one of the keywords I'd used was "Nexus", which wasn't present in that bug summary.

Thanks :-)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(snorp)
Resolution: --- → DUPLICATE
Duplicate of bug: 1221228
You need to log in before you can comment on or make changes to this bug.