[Aries KK][First Time Experience]At "About Firefox OS" view, user can't switch among Basic and Enhanced and None button.

RESOLVED INVALID

Status

Firefox OS
Gaia::First Time Experience
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Tony(Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
[1.Description]:
[Aries KK v2.5][First Time Experience]At "About Firefox OS" view, user can't switch among Basic and Enhanced and None button.
See attachments: Aries_KK_v2.5.3gp&logcat_1258.txt
Found time: 12:58.

[2.Testing Steps]: 
1. Flash a fresh build on the phone. Begin navigation through the first time setup screen. 
2. Tap Next button.
3. Switch among Basic, Enhanced and None button in the About Firefox OS view.

[3.Expected Result]: 
3. User can switch among Basic, Enhanced and None button at "About Firefox OS" view.

[4.Actual Result]: 
3. User can't switch among Basic, Enhanced and None button at "About Firefox OS" view.

[5.Reproduction build]: 
Device: Aries KK v2.5(Affected)
Build ID               20151116174534
Gaia Revision          9473dbcbebf4e758a3b73200968efc69071b4312
Gaia Date              2015-11-16 15:49:25
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/17877d161e5f62726027ee70101a7004dcad5a69
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151116.165317
Firmware Date          Mon Nov 16 16:53:25 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 512mb(Unaffected)
Build ID               20151116173604
Gaia Revision          9473dbcbebf4e758a3b73200968efc69071b4312
Gaia Date              2015-11-16 15:49:25
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/17877d161e5f62726027ee70101a7004dcad5a69
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151116.164743
Firmware Date          Mon Nov 16 16:47:52 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.6 master(Unaffected)
Build ID               20151112120735
Gaia Revision          27bc9412ca607648bc398b25bb1ae25653b2b278
Gaia Date              2015-11-12 02:27:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3cc3b1968524248450c465c4ea2ee5596ffa65f2
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151112.112635
Firmware Date          Thu Nov 12 11:26:43 UTC 2015
Bootloader             s1

Device: Flame KK v2.6 master 512mb(Unaffected)
Build ID               20151115150212
Gaia Revision          e8c15ae4e5324a210000ee0a869a962aa542009f
Gaia Date              2015-11-13 00:10:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7cd2d806bd069c0260ff73f023ac85f892b863bf
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151115.184416
Firmware Date          Sun Nov 15 18:44:31 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
(Reporter)

Comment 1

2 years ago
Created attachment 8688346 [details]
logcat_1258.txt
(Reporter)

Comment 2

2 years ago
Created attachment 8688349 [details]
Aries_KK_v2.5.3gp
(Reporter)

Updated

2 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → unaffected
Tamara, can you look into this?
Flags: needinfo?(thills)
Hi Tony,

Is this on a foxfooding build?  I could not tell from the video whether the buttons were greyed out or not.

Thanks,

-tamara
Flags: needinfo?(tianxu)
(Reporter)

Comment 5

2 years ago
Hi Tamara,  
  I use the dogfood build, and you can get from link below: https://tools.taskcluster.net/task-inspector/#Tu0JIIpGTKKH532KT_0jfA/. At "About Firefox OS" view, Basic, Enhanced and None button are grey, user can't switch among Basic and Enhanced and None button. thanks
Flags: needinfo?(tianxu)
Hi Tony,

This is expected behavior for the dogfood builds.  

Thanks,

-tamara
Flags: needinfo?(thills)

Comment 7

2 years ago
Marked as RESOLVED INVALID since it is expected behavior.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.