Link pointer leaves artifacts when page is scrolled with mouse wheel

RESOLVED WORKSFORME

Status

()

--
trivial
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: brent, Assigned: attinasi)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
If you go to a page w/ a link and put your mouse over the link to get the hand
pointer, and then scroll the page up or down with a mouse wheel, it leaves a
bunch of hand pointer artifacts (I'm not sure what else to call them) on the
page that stay there.  This is on a Mac, tested w/ both a MS Intellimouse and a
Kensington Optical Elite mouse.  This has been happening on all builds I've
tried for the last few months.  I tried to find a similar bug that was filed in
the bug DB but couldn't, so if this is a dupe, feel free to mark it as such.

Comment 1

17 years ago
Created attachment 73208 [details]
A screenshot when I scroll over a link

Comment 2

17 years ago
Sort of WorksForMe using Mac/2002052305 (1.0). The scroll wheel only succeeds in scrolling the page 
one tick. Then it just sits there and fails until you manipulate the elevator again, then you can scroll one 
tick again. Sigh. <editorial>Mozilla for Classic Mac OS has really gone to the dogs since I switched to OS 
X.</editorial> In any event, no extra pointers are drawn during that one pathetic little scroll wheel tick.

Brent, is this problem still reproducible using a current build?
(Reporter)

Comment 3

17 years ago
Yes, the same behavior happens in Build 2002061103 (1.1Alpha).  And looks just
like the Attachment.  I used to get the "one tick" thing as well, but that was
when I used a different mouse.  The MS Intellimouse Explorer scrolls the page
fine, but then I get these artifacts.

Comment 4

16 years ago
Drawing problem; try Layout.
Assignee: asa → attinasi
Severity: normal → trivial
Component: Browser-General → Layout
QA Contact: doron → petersen

Comment 5

16 years ago
Hmm. Using a Logitech scrolling mouse (with Mouseware 4.0.3), I can't reproduce
issue with July 17th build (2002-07-17-05) under OS 9.1.
Reporter: can you still reproduce this on a recent nightly ?
Guess not :)

Reporter: please reopen this bug if you still see it with a recent nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.