<mtable> <mtr> <mtd> <mtext/> </mtd> </mtr> </mtable> hangs mozilla

RESOLVED DUPLICATE of bug 236326

Status

()

Core
MathML
--
critical
RESOLVED DUPLICATE of bug 236326
17 years ago
14 years ago

People

(Reporter: Michel Goossens, Assigned: rbs)

Tracking

({hang, pp})

Trunk
x86
Linux
hang, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011230
BuildID:    2001123017

When I try and view my document (via the above URL or as a local file)
Mozilla (with SVG+MatmML support, as downloaded from the Mozilla download
directory) display nothing, but Mozilla seems to go into a loop, consuming all
CPU cycles available on the machine. This happens with version 0.9.7 both on
Linux (build 2001123017), Windows 2000 
(build 2002010204, i.e., version 0.9.7, and build 2002012709, a nightly build of
pre-0.9.8, binaries I picked up on Monday Jan 28th and today Jan 30th have the
same behavior). Amaya has no problem with that file and displays it correctly

Reproducible: Always
Steps to Reproduce:
1. Enter above URL into browser
2.
3.

Actual Results:  Mozilla shows nothing and goes into aloop

Expected Results:  Show the contents
(Assignee)

Comment 1

17 years ago
Created attachment 67065 [details]
screenshot - rendering of the page

Works for me on Windows with a more recent build.
Hixie, do you reproduce the problem when visiting the page?

Comment 2

16 years ago
Confirmed on Linux 0.9.9 branch using 2002030508. Other MathML pages work on
this system with this build. No similar bugs in MathML were found in Bugzilla.

mozilla process goes to 100% CPU and never comes back, therefore I hope I'm not
treading on anyone's feet by adding crash, and setting Severity = critical.

I don't have the "extra" MathML fonts, but this page crashes before it can warn
me about that anyway. I tested only on Linux, Red Hat 7.2 + updates.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
This time really marking crash/ critical
Severity: normal → critical
Keywords: crash
(Assignee)

Comment 4

16 years ago
is this still a problem with the official m0.9.9 release build?

hixie, did you see my question in comment #1, two months ago?
Oops, nope, sorry. I'll take a look in a sec (can't check crashers and hang bugs
until I have finished reading all open tabs).
Summary: Nothing shows (Mozilla goes into a loop) → [Hixie] Nothing shows (Mozilla goes into a loop)

Comment 6

16 years ago
Seconds are very long where Hixie is. Reproduced in 0.9.9 Linux build.

Ugh. Is there really no-one working on this component with Unix? Why is a bug
assigned to someone who is powerless to fix it?
Keywords: crash → hang, pp
Summary: [Hixie] Nothing shows (Mozilla goes into a loop) → <mtable> <mtr> <mtd> <mtext/> </mtd> </mtr> </mtable> hangs mozilla
Created attachment 78138 [details]
Testcase: Simplified

This triggers the bug on Mandrake 8.1 (Linux). Note that the presence of XHTML
is required to trigger the bug.
(Assignee)

Comment 8

16 years ago
*** Bug 134404 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
Created attachment 104111 [details]
XHTML+MathML that causes Mozilla to hang

Comment 10

16 years ago
Created attachment 104113 [details]
LaTeX source for preceding example

I've also attached the TeX source that I used to generate the example, in case
the problem is with mzlatex's output.  (If so, a little more feedback from the
browser would be appreciated ...)
If Mozilla hangs or crashes, it's a Mozilla bug, regardless of what the input
may look like.
(Assignee)

Comment 12

14 years ago
I am unconventionally marking as a suplicate of the more recent bug 236326
because it has a patch.

*** This bug has been marked as a duplicate of 236326 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.