If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

cursor movement quirks when editing text entry fields

VERIFIED DUPLICATE of bug 82151

Status

()

Core
HTML: Form Submission
--
trivial
VERIFIED DUPLICATE of bug 82151
16 years ago
16 years ago

People

(Reporter: Ingo Wilken, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122108

The cursor shows some funny behaviour when editing text in form fields
and using the cursor keys to move around.



Reproducible: Always
Steps to Reproduce:
1.Type some text in an empty entry field.
2.Move the cursor around (cursor keys).  When trying to move past the end of the
entered text, the cursor goes back to the first char. But the  cursor does not
go to the end when hitting Cursor-Left on the first char.
3.Sometimes, step 2 does not work.  This seems to happen when the text field
already had some text in it (e.g., this "Steps to Reproduce" field shows this
behaviour when it's still "empty").
4.On multi-line texts, type some text so that the last word on a line  fits
exactly into the entry field's width.  Then hit space: The cursor seems to be
glued to the end of the word, it does not move into the next line.  Then hit
backspace: Although the cursor still seems to be just behind the last char of
the word, it does not delete that char, but the "invisible" space after the
word, and the cursor does not move.
5. While the cursor is on the very end of the text, hit Cursor-Down, then
Cursor-Left or Cursor-Right.  The cursor jumps to somewhere in the middle or
beginning of the last line.

Actual Results:  See above.

Expected Results:  For step 2, move to the last char of the field when hitting
Cursor-Left on the first char.
For step 3, consistent behaviour with step 2.
For step 4, move the cursor to the next line as soon as the user hits Space.
For step 5, go to the beginning of the text with Cursor-Right (to be consistent
with the behaviour in step 2), and simply one char left with Cursor-Left.
Duplicate of "Right arrow key at end of a TEXTAREA goes to the beginning"

The other issues you list are duplicates of this and other reported problems...
In the future, please file one issue per bug report.

*** This bug has been marked as a duplicate of 82151 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verifying duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.