Docs: Make it clearer how to create hawk credentials locally

RESOLVED FIXED

Status

Tree Management
Treeherder: Docs & Development
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: emorley, Assigned: emorley)

Tracking

Details

(Assignee)

Description

2 years ago
We have a guide here:
http://treeherder.readthedocs.org/common_tasks.html#managing-api-credentials

However it's not linked from the submitting data page where people are actually looking:
http://treeherder.readthedocs.org/submitting_data.html#authentication

Comment 1

2 years ago
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/6df3aa4ac3dfee1da6121fc3c747e0ab4313dee8
Bug 1225597 - Docs: Make local hawk credentials section easier to find

Also remove the duplication between the two pages, by having the
submitting data section not mention requesting credentials at all, and
leave that to the common tasks page instead.

https://github.com/mozilla/treeherder/commit/5f9a57ef21a214ca8db432535325482c77f5ca12
Bug 1225597 - Docs: Use anonymous links to avoid build warnings

Fixes:
common_tasks.rst:2: WARNING: Duplicate explicit target name: "stage".
common_tasks.rst:2: WARNING: Duplicate explicit target name: "production".

http://docutils.sourceforge.net/docs/ref/rst/restructuredtext.html#anonymous-hyperlinks
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1083372
You need to log in before you can comment on or make changes to this bug.