Delete message is not moving to mailbox, instead just marks as deleted (despite account settings)

RESOLVED DUPLICATE of bug 491424

Status

RESOLVED DUPLICATE of bug 491424
3 years ago
3 years ago

People

(Reporter: david, Unassigned)

Tracking

42 Branch
x86_64
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8688939 [details]
thunderbird-move.log

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151112144305

Steps to reproduce:

1. Make sure Tools -> Account Settings -> main server -> Server Settings -> Server Settings -> When I delete a message -> "Move to this Folder is checked and a folder on my IMAP server is selected.
2. Select a message in my Inbox.
3. Delete it (with the delete key or using the toolbar or the menu)



Actual results:

The message is marked as deleted.


Expected results:

It should be moved into the Trash folder.

I turned on IMAP logging by launching Thunderbird thusly:

$ env NSPR_LOG_MODULES=IMAP:4 NSPR_LOG_FILE=/tmp/imap.log /Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin

Attached are 2 logs:

   The one labelled "move" was captured when I manually moved the same message (after undoing the delete) to the Trash folder. This log clearly shows an entry where the message is copied to INBOX.Trash. This tells me that the server is working correctly (Cyrus IMAP on Debian).

   The one labelled "delete" was captured when I pressed the delete key to delete a message. In this log there is no "copy"—I only see an entry that sets the \Deleted and \Seen flags.

So I think Thunderbird is the problem here. I've tried changing the Trash mailbox to other mailboxes in the account setting and it doesn't help. None of them ever get the deleted messages.
(Reporter)

Updated

3 years ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

3 years ago
Created attachment 8688940 [details]
thunderbird-delete.log
(Reporter)

Comment 2

3 years ago
(I replaced the domain name with example.com in the logs I attached)
(In reply to david from comment #0)
> Steps to reproduce:
> 1. Make sure Tools -> Account Settings -> main server -> Server Settings ->
> Server Settings -> When I delete a message -> "Move to this Folder is
> checked and a folder on my IMAP server is selected.

Your test with "move" was "move to Inbox.Trash". And it's Cyrus.
It looks "personal namespace=INBOX." and "INBOX.INBOX can have mail only. Can not have subfolder".

What is set in mail.server.server#.trash_folder_name by your "trash folder setting"?

If namespce="INBOX." and if "trash folder which you want to use with Move to TMash model"==Inbox.Trash, it should be mail.server.server#.trash_folder_name=Trash.
mail.server.server#.trash_folder_name=INBOX/Trash means that trash what you want to use==INBOX.INBOX.Trash if "namespace=INBOX."
This is curentl design. (i.e.vurrently bug in "trash folder selection UI")
And, Cyrus may reject creation of folder named INBOX.INBOX.Trash because of "INBOX.INBOX can have mail only".
This may produce "no trash folder(folder which has special folder attribute=Trash) condition" in Tb.

Dup of bug 491424? See also bug	480393 and bug 836631.
(Reporter)

Comment 4

3 years ago
Ah, yes, that does appear to be the case. My "trash_folder_name" was set to "INBOX/Trash". I had an INBOX.INBOX.Trash folder show up at some point, but it was always empty and so I deleted it.

Interestingly, I ended up fixing it without having to muck with the raw prefs: I went to my account settings, I selected "Just mark it as deleted" for the "When I delete a message" setting, clicked "OK" and deleted a message. Then I went back into account settings, changed it to "Move it to this folder" and then re-selected my correct Trash folder and clicked "OK" again. At that point it started working (deleting messages was actually moving them to the correct Trash folder). Sure enough, checking the raw prefs shows that the "trash_folder_name" for my account is now set to just "Trash".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491424
You need to log in before you can comment on or make changes to this bug.