Closed Bug 1225847 Opened 7 years ago Closed 7 years ago

[TV] Smart-Home FTE, part 2

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, feature-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
blocking-b2g 2.5+
feature-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: rexboy, Assigned: rexboy)

References

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(1 file)

We need to add the second page of first-time use for smart-home.
Refer to spec:
https://drive.google.com/folderview?id=0B4K8q1qWmtAvdUJFYUx5NFBEaVk&usp=sharing&tid=0B2-G3kew1WpXLURNc29vTWl5eUk

Also the page.1 picture need to be updated for removing the browser icon.
No longer depends on: 1220588, 1199313
Assignee: nobody → rexboy
Comment on attachment 8689958 [details] [review]
[gaia] rexboy7:1225847-fte-home-part-2 > mozilla-b2g:master

Hi Yifan,
based on the updated visual, I added FTE page2 for smart-home. Fortunately no javascript changes needed (But I added some comments for necessary styles for FTEWizard)
Can you help review it?
Attachment #8689958 - Flags: review?(yliao)
feature-b2g: --- → 2.5+
Status: NEW → ASSIGNED
QA Whiteboard: [COM=TV FTU]
Comment on attachment 8689958 [details] [review]
[gaia] rexboy7:1225847-fte-home-part-2 > mozilla-b2g:master

LGTM! Thanks!
Attachment #8689958 - Flags: review?(yliao) → review+
master
https://github.com/mozilla-b2g/gaia/commit/874f626cbfb5e7dbc59ddb51069975ebfd2c8fe9
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8689958 [details] [review]
[gaia] rexboy7:1225847-fte-home-part-2 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): feature
[User impact] if declined: FTE page of smart-home doesn't show on first time.
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky): small
[String changes made]: yes
Attachment #8689958 - Flags: approval-gaia-v2.5?
blocking-b2g: --- → 2.5+
Comment on attachment 8689958 [details] [review]
[gaia] rexboy7:1225847-fte-home-part-2 > mozilla-b2g:master

Approve for TV 2.5 Smart-Home FTE
Attachment #8689958 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.