Upgrade raven and Sentry DSN

RESOLVED FIXED

Status

Webtools
Peekaboo
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: peterbe, Assigned: peterbe)

Tracking

(Blocks: 1 bug)

Trunk
Dependency tree / graph

Firefox Tracking Flags

(firefox45 affected)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
We have a new Sentry at https://sentry.prod.mozaws.net/operations/

We need to upgrade raven and generate new API keys and deploy those.
(Assignee)

Updated

2 years ago
Depends on: 1227238

Updated

a year ago
Depends on: 1303900
(Assignee)

Updated

a year ago
Assignee: nobody → peterbe
(Assignee)

Comment 1

a year ago
piprot says...:

raven (5.9.0) is 283 days out of date. Latest is 5.27.1
(Assignee)

Comment 2

a year ago
Looots of things have improved since version 5.9.0
https://github.com/getsentry/raven-python/blob/c46f17727d4b980e55e4813082f1dbce3d3ab7bd/CHANGES#L173
We run a Sentry server (8.3.3) that doesn't support Breadcrumbs but it's OK. It just gets ignored in processing.
(Assignee)

Comment 3

a year ago
Created attachment 8794910 [details] [review]
Link to Github pull-request: https://github.com/mozilla/socorro/pull/3487
(Assignee)

Updated

a year ago
Blocks: 1306731

Comment 4

a year ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/389844bca9b164ee8ce014a1793fa235c908dac4
fixes bug 1225863 - upgrade to raven 5.27.1 (#3487)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.