canvas drawImage from usermedia upside down

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
3 years ago
9 months ago

People

(Reporter: alexnigl, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(firefox43 affected, firefox44 unaffected, firefox45 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8689025 [details]
proof of bug

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151113105403

Steps to reproduce:

(0. Use Nexus 5: Android 6.0)
1. GoTo: https://rawgit.com/AlexNigl/4340d560ac6a61dca9d8/raw/c3866daac2f3389109686fcc804ee24abc6fe807/index.html
2. allow camera permissions
3. click on video to make a snapshot


Actual results:

An upside down snapshot of the current video appears.


Expected results:

A snapshot of the current video appears. (not upside down).
This works for me in Firefox 44 and 45 but I can reproduce on Firefox 43 using a Nexus 5 and Nexus 5x running Android 6.  Is this important enough to find the fix and uplift to beta assuming the fix is deemed safe enough?
tracking-fennec: --- → ?
status-firefox43: --- → affected
status-firefox44: --- → unaffected
status-firefox45: --- → unaffected
Let it ride the trains
tracking-fennec: ? → ---
Works for me then on 44a2 and 45a1. Builds are at https://aurora.mozilla.org and https://nightly.mozilla.org
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 4

11 months ago
Please reopen. It is reproducible on Xiaomi Mi 4 with Firefox 53.0.3.

Comment 5

11 months ago
We get this problem too, reproducible on MiPhone 5s plus,Android 6.0.1. It affects our application, see https://github.com/linagora/hublin/issues/69

Comment 6

9 months ago
Same here. Reproducible on Samsung S4 and A5 with Firefox 54.0.1
File a new bug. This bug was resolved it is confusing to open a new bug for such an old issue. Especially since I checked that it was broken in Firefox 43 but fixed in 44.
You need to log in before you can comment on or make changes to this bug.