Firefox Hello isn't available in Iran

RESOLVED INVALID

Status

P4
normal
Rank:
45
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: amir_farsi, Unassigned)

Tracking

({thirdparty})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151117004023

Steps to reproduce:

Hi all.
Why Firefox Hello showing this message to Iranian users:
Firefox Hello is not available in your country.



Expected results:

Firefox Hello is like Skype and ooVoo and other video chat apps.
Those are avilable in Iran. Why Firefox Hello isn't?
(Reporter)

Comment 1

3 years ago
Created attachment 8689039 [details]
FirefoxHelloIran.jpg

Firefox Hello Message for Iranian users!
Assignee: nobody → rtestard
Assignee: rtestard → nobody
Rank: 45
Priority: -- → P4

Comment 2

3 years ago
Hi Amir, Hello uses the TokBox back-end whose ToS are https://tokbox.com/support/tos
(please check-out section 20 for details). Since the back-end does not allow us to run the Hello service in Iran we had to implement the UI in Firefox to inform that Hello is not supported in Iran, sorry we cannot provide you service there!
I'll close the bug, feel free to re-open if you need more details.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

3 years ago
Hi Romain.
I that page which you linked in comment 2 says Iran because Iran's sanctions and OFAC legal about it.
But it was for few years ago. They doesn't updated their Terms of Service.
I want inform you and Mozilla that OFAC published a General License which allowed comanies for selling anything is related to communication technology and computer hardware/software.
You can Visit here https://www.treasury.gov/resource-center/faqs/Sanctions/Pages/faq_iran.aspx and which is official OFAC site abou Iran's sanctions FAQ, and find for communication word and read about it.
Also you can get licence from OFAC official site and read it from here: https://www.treasury.gov/resource-center/sanctions/Programs/Documents/soc_net.pdf
Also useful info is available here: https://www.treasury.gov/resource-center/sanctions/Programs/Pages/iran.aspx
After this license, all of companies such as Yahoo, Google, Skype and Apple removed Iran's blocking Iranian Users. 

Finally, I think Mozilla should be request from Telefonica and tokbox for allow Iranian users to use Firefox Hello.
Thanks.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(romain.tisserand)
Resolution: WONTFIX → ---

Updated

3 years ago
Flags: needinfo?(romain.tisserand)

Comment 4

3 years ago
Please remove me from this as I'm not involved in.
(Reporter)

Comment 5

3 years ago
In addition, Mozilla and Telefonica can ask officially from OFAc about allow Iranian users to use Firefox Hello and takbox! It's easy as an official email to OFAC from Mozilla.
(Reporter)

Updated

3 years ago
Flags: needinfo?(rtestard)
(Reporter)

Comment 6

3 years ago
Also I want share references which shows other companies allowed Iranian users to use their products:
http://www.apple.com/legal/more-resources/gtc.html
http://blogs.wsj.com/riskandcompliance/2013/08/26/google-offers-iranians-play-store-access/
http://blog.coursera.org/post/74891215298/update-on-course-accessibility-for-students-in

Also this link is useful:
http://www.steptoe.com/resources-detail-8103.html (Find for Yahoo Messenger and Firefox)
Tokbox are aware of the changes in status of Iran, and are looking at the legal implications. There appears to be some issues which prevent them allowing Iran at the moment, but they are working through them with their lawyers. Unfortunately there's no ETA.

We'll continue to monitor the progress with them, but I don't think its worth us keeping a bug open for this at the moment, as there's not much we can do ourselves.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(rtestard)
Keywords: thirdparty
Resolution: --- → INVALID

Comment 8

3 years ago
I can confirm that in Cuba also happens, maybe the solution is fix the bug
https://bugzilla.mozilla.org/show_bug.cgi?id=1024548
You need to log in before you can comment on or make changes to this bug.