Bring Java plugin back in-process

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: David DeHaven, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/601.2.7 (KHTML, like Gecko) Version/9.0.1 Safari/601.2.7

Steps to reproduce:

In Firefox 42, the Java plugin was moved out of process due to:
https://bugzilla.mozilla.org/show_bug.cgi?id=1140616

Specifically, Firefox began intentionally causing a crash when it detects NPAPI calls being made in a thread other than the main browser thread. This exacerbated the problem and made it much more prevalent, leading to moving the Java plugin out of process to prevent it from bringing the entire browser down (only the plugin process would crash then). The threading bug was fixed in a respin of Java 8 update 66 for Windows, released as build 18. With this build installed, we can no longer reproduce the crash reported in the above bug or any of the related issues that lead to Firefox implementing the thread check.

Unfortunately, as a result of being moved out of process, there have been a number of complaints about the plugin becoming unresponsive, due to a known issue between the plugin crash detector and the Java plugin event handler.

The only workaround at the moment, for those with 8u66 build 18 installed, is to manually set dom.ipc.plugins.java.enabled to false. Changing this setting is cumbersome as it does not show up in the list by default, the user must manually add it via about:config or by hand modifying preferences files. Neither option is without risk, particularly for non-technical end-users.

The problem being caused by this is tracked by:
https://bugzilla.mozilla.org/show_bug.cgi?id=1222036

That issue includes several test cases for reproducing the problem.

We believe the quickest resolution for this would be to move the Java plugin back in-process until a longer term solution can be implemented.



Actual results:

Java 8u66 build 18 plugin is unstable when showing a modal dialog


Expected results:

Java 8u66 build 18 plugin should be more stable when showing a modal dialog
(Reporter)

Updated

3 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 1

3 years ago
In Firefox 43 we have removed support entirely for in-process NPAPI plugins. This helps mitigate several other security threats and simplify our internal code paths and we are not going to move Java back in-process. The dom.ipc.plugins.java.enabled pref will stop working in Firefox 43.

This work was implemented/tracked in bug 1194780.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Comment 2

3 years ago
Hi Benjamin,
We are affected by the issue with the Java Plugin crashing in Firefox 42. We are an enterprise vendor with thousands of customers using Firefox browser. We would have many customers seriously affected by this issue. I wanted to appeal to you if there was any chance that removal of the dom.ipc.plugins.java.enabled setting can be postponed until Oracle can fix the issue on their side. We would really appreciate this.

We are in the process of phasing out applets from our application. But at this point we do need the support until the stated deadline of end of next year.

Thanks,

Atul Kshatriya
You need to log in before you can comment on or make changes to this bug.