Crash opening a bogus xul file.

VERIFIED DUPLICATE of bug 12183

Status

()

P3
normal
VERIFIED DUPLICATE of bug 12183
20 years ago
11 years ago

People

(Reporter: morse, Assigned: trudelle)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Create a file with a .xul suffix and containing a single line, namely

XUL file:

Then open this file up in the browser.  You get the following crash.  This was
discovered quite by accident in the process of investigating bug 11016.

NTDLL! 77f76274()
nsExpatTokenizer::GetLine(const char * 0x0310fbe0, unsigned int 18, unsigned int
0, nsString & {...}) line 199 + 43 bytes
nsExpatTokenizer::PushXMLErrorToken(const char * 0x0310fbe0, unsigned int 18,
int 0) line 271
nsExpatTokenizer::ParseXMLBuffer(const char * 0x0310fbe0, unsigned int 18, int
0) line 289
nsExpatTokenizer::ConsumeToken(nsScanner & {...}) line 330 + 18 bytes
nsParser::Tokenize(int 0) line 1264 + 21 bytes
nsParser::ResumeParse(nsIDTD * 0x00000000, int 0) line 885 + 12 bytes
nsParser::OnDataAvailable(nsParser * const 0x034268a4, nsIChannel * 0x0343bed0,
nsISupports * 0x00000000, nsIInputStream * 0x0343e1a0, unsigned int 0, unsigned
int 9) line 1168 + 19 bytes
nsDocumentBindInfo::OnDataAvailable(nsDocumentBindInfo * const 0x0345fbd0,
nsIChannel * 0x0343bed0, nsISupports * 0x00000000, nsIInputStream * 0x0343e1a0,
unsigned int 0, unsigned int 9) line 2057 + 32 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x0343ae70)
line 350
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x0343ae74) line 149 + 12 bytes
PL_HandleEvent(PLEvent * 0x0343ae74) line 509 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00afb840) line 470 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x21c001c0, unsigned int 49404, unsigned int 0,
long 11515968) line 932 + 9 bytes
USER32! 77e71268()
00afb840()
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

20 years ago
This looks like another case of nsiStreamListener not handling an empty
document.


*** This bug has been marked as a duplicate of 12183 ***

Updated

20 years ago
QA Contact: ckritzer → morse

Comment 2

20 years ago
Assigning to originator per new organizational structure.

Updated

19 years ago
QA Contact: morse → ckritzer

Comment 3

19 years ago
Changing QA Contact back to ckritzer@netscape.com

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Marking VERIFIED DUPLICATE per trudelle's comments.

Comment 5

19 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Updated

11 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: ckritzer → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.