Allow re-installing a temporary add-on

VERIFIED FIXED in Firefox 47

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: mossop, Assigned: jryans)

Tracking

(Blocks: 1 bug)

Trunk
mozilla47
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 affected, firefox47 fixed, firefox51 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Currently installTemporaryAddon bails if an add-on with the same ID is already temporarily installed. We should make it do something sane, probably just uninstall the old and install the new.

Updated

2 years ago
Blocks: 1226743
(Assignee)

Updated

2 years ago
Blocks: 1246030
(Assignee)

Updated

2 years ago
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Keywords: dev-doc-needed
(Assignee)

Comment 1

2 years ago
Created attachment 8721586 [details] [diff] [review]
reinstall-temp
Attachment #8721586 - Flags: review?(dtownsend)
(Reporter)

Comment 2

2 years ago
Comment on attachment 8721586 [details] [diff] [review]
reinstall-temp

Review of attachment 8721586 [details] [diff] [review]:
-----------------------------------------------------------------

Huh, I was surprised that this just worked as-is. Looks like the database doesn't care about you removing an old entry when adding a new one though so looks good enough and we have tests to make sure that if we ever change that we'll catch it. Awesome!
Attachment #8721586 - Flags: review?(dtownsend) → review+
(Assignee)

Comment 3

2 years ago
Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b0646b516a21

Comment 4

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/62f627d7e115

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/62f627d7e115
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Keywords: dev-doc-needed

Comment 6

a year ago
This issue is verified as fixed on Firefox 51.0a1 (2016-09-14) on Windows 7 64-bit.

I can confirm that an old temporary add-on it will be uninstalled if a new temporary add-on with the same ID will be installed.
Status: RESOLVED → VERIFIED
status-firefox51: --- → verified
You need to log in before you can comment on or make changes to this bug.