Inspector panel stays empty when opening the Tools while a page is still loading

RESOLVED DUPLICATE of bug 1151909

Status

defect
RESOLVED DUPLICATE of bug 1151909
4 years ago
a year ago

People

(Reporter: sebo, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(firefox45 affected)

Details

Reporter

Description

4 years ago
If you open the Inspector or the Style Editor panel while a page is loading, the panel stays empty and I get the following error in the Browser Console:

"Protocol error (unknownError): [Exception... "Unexpected error"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/highlighters/utils/markup.js :: CanvasFrameAnonymousContentHelper.prototype._insert :: line 236"  data: no]"1 Promise-backend.js:937

Steps to reproduce:
1. Go to https://www.mozilla.org/en-US/
2. While the page is still loading press open the Inspector (Ctrl+Shift+C)

This only seems to happen for the Inspector and the Style Editor panel. I also tried it with the Console, Debugger and Network panel, though they work as expected.

Sebastian
For the inspector-panel, this is bug 1151909.
For the style-editor, this is bug 1224558 comment 1.

Going to duplicate this with bug 1151909.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151909
Both of these bugs are potentially complex. We've had the bug for the inspector-panel opened for as long as I can remember working on the team. Sad that we've never found the time or energy to work on it ...
I might take a look at the style-editor bug.
Reporter

Comment 3

4 years ago
Thank you for pointing me to the right bugs.

Sebastian

Updated

a year ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.