Hangs turning on/off web console in responsive view

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
6 months ago

People

(Reporter: riksoft, Unassigned)

Tracking

52 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20151015173334

Steps to reproduce:

(FF Developer edition 64bit on Mint 13 64 bit. I7, 8GB RAM.
Tested with 0 add-ons. Also tested after a reset and new profile)

I simply load a page that uses bootstrap and jQuery (both in the local FS), and: 
CTRL+SHIFT+M (web console)
F12

Now I works as usual, reloading the page to test the new code I'm developing.


Actual results:

Not rarely, when pressing F12 to close the web console, FF hangs.

If I try to close it (button x on the windows), after 10s Mate ask me "Firefox is not responding, do you want to kill?".
Actually is not completely frozen because waitin a minute it really close properly.

Unfortunately I can't reproduce it systematically.

There is a SIMILAR behaviour (but it's not the same because you can close FF without killing it) due to the Inspector picker. Try this:
F12
click the inspector picker
now press F12 and nothing happen unless you click some other buttons. While the inspector picker is enabled F12 doesn't work and this is a bit deceiving... but it's not the subject of this bug report.


Expected results:

I expect FF to close the web console without freezing.
(Reporter)

Updated

3 years ago
Component: Untriaged → Developer Tools
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Do you still see this issue with more recent versions of Firefox?
Flags: needinfo?(riksoft)
(Reporter)

Comment 2

3 years ago
I forgot about this problem so I suppose it's fine now. :-)
At the moment I'm using v.43.
Thanks.
Flags: needinfo?(riksoft)
Thanks for following up
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

2 years ago
The problem is back again, but now is more general and I wonder how can I narrow this behaviour to say something more specific.

Few minutes ago, I've clicked a bookmark to a localhost page and the browser almost froze. 
I can still click menus but I have to wait 30s each.

Sounds like JS in loop but it's not (I'm on localhost, the source is mine and the behaviour is one-off, so it's not in the code).
Moreover there is not CPU heavy usage by Firefox, seems like a loop with sleep().

This has always and only happened with the Developer Edition, never with the standard edition.
In this moment I'm using 52.0a2 (2016-12-14) (64-bit).

How can I help on this problem?
(Reporter)

Comment 5

2 years ago
I've been stuck for 10 minutes now. I was trying to launch about:performance.
top still show no CPU usage.
I've closed Netbeans and immediately Firefox resuscitated.
So maybe is something connected with Netbeans. I'll check it again the next time.
Could be that it happens only when FF is started by F6 or Shift-F6 in Netbeans.
I'll be back... :-)
Version: 43 Branch → 52 Branch

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.