Australis menu sidebars render in a wrong way

VERIFIED DUPLICATE of bug 1227210

Status

()

Core
Graphics
VERIFIED DUPLICATE of bug 1227210
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

Trunk
Unspecified
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 unaffected, firefox45- fixed)

Details

(Whiteboard: gfx-noted, URL)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 45, 32bit, ID 20151119030404
STR:
1. Click australis menu (≡)
2. Click Help Menu button (?)

Result:       
 Sidebar isn't rendered normally until you stop moving the mouse

> screencast:   https://dl.dropboxusercontent.com/s/k1dk1bf1jcn4w63/video%20-%20Australis%20menu%20sidebars%20render%20in%20a%20wrong%20way.webm?dl=0
(Reporter)

Comment 1

2 years ago
It was regressed between 2015-11-11 and 2015-11-12 by bug 1210560
> pushlog_url:   https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1e5f3d1151d60a1edd6424a35a2e38b5ab17adad&tochange=af5c9cf6898b0e2931a809774387cad5953363c3
Bas, can you also please take a look at this?
Flags: needinfo?(bas)
See Also: → bug 1224974
Whiteboard: gfx-noted
OS: Unspecified → Windows 7

Comment 3

2 years ago
Via local build(win32),
Last Good: 2ccdc96a5559
First Bad: 2afe2414f3fc

Triggered by: 2afe2414f3fc	Bas Schouten — Bug 1210560 - Part 5: Convert BasicLayers usecases to PushGroupForBlendBack and temporary surfaces. r=jrmuizel
Hrm, I can't seem to reproduce this. Did I possibly already push a fix for this? Are you still seeing it in current builds, and if so, could you post a screenshot of what the glitch looks like?
Flags: needinfo?(bas)

Comment 5

2 years ago
Created attachment 8690584 [details]
screenshot

Comment 6

2 years ago
Created attachment 8690585 [details]
capture
[Tracking Requested - why for this release]: regression.
tracking-firefox45: --- → ?

Comment 8

2 years ago
A patch for bug 1227210 may fix this.
On my build with the patch, I can't reproduce the problem.
Depends on: 1227210
(Reporter)

Updated

2 years ago
Has STR: --- → yes
(Reporter)

Comment 9

2 years ago
>>>   My Info:   Win7_64, Nightly 46, 32bit, ID 20160116030240
Fixed by bug 1227210
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1227210
(Reporter)

Comment 10

2 years ago
Verified in comment 9
Status: RESOLVED → VERIFIED
status-firefox45: affected → fixed
tracking-firefox45: ? → -
You need to log in before you can comment on or make changes to this bug.