Crashes following calendar/contacts sync between Lightning and OwnCloud

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: macho.p, Unassigned)

Tracking

({hang, perf})

38 Branch
hang, perf

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151030083518

Steps to reproduce:

Thunderbird became unstable when I installed Lightning to sync my address book and calendar to OwnCloud. This includes various crashes, hangs, and other bizarre behaviour. One consistent feature is that Thunderbird doesn't exit when I exit the GUI and has to be killed from the command line.

I'm including some sample console output below with a stack trace and DBus's scary "Application may misbehave" warning. I'm not sure whether this encapsulates the whole problem, but I hope that it is enough to go on. Any thoughts on how to fix this?

OS: Ubuntu 15.10
Thunderbird: 38.3.0
Inverse Sogo connector: 31.0.2
Lightning: 4.0.3.1
KeePass Helper 3.0.2.1-signed
Module d'Antidote: 8.38.59 [This module has caused me problems in the past, but not recently, and doesn't seem to be the culprit here]
I also have a handful of other add-ons installed that I believe are working fine, and have been for some time.


Actual results:

$ thunderbird 

(process:21341): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
[calBackendLoader] Using libical backend at /home/macho/.thunderbird/macho.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libical-manifest
Warning: Use of getPrefSafe() is deprecated and will be removed with the next release. Use Preferences.get() instead.
1: [chrome://calendar/content/calUtils.js:471] getPrefSafe
2: [chrome://sogo-connector/content/calendar/calendar-event-dialog-overlay.js:15] SCOnLoad
3: [null:0] null

Warning: Use of getPrefSafe() is deprecated and will be removed with the next release. Use Preferences.get() instead.
1: [chrome://calendar/content/calUtils.js:471] getPrefSafe
2: [chrome://sogo-connector/content/calendar/calendar-event-dialog-overlay.js:15] SCOnLoad
3: [null:0] null

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)" 
QFSFileEngine::open: No file name specified

(thunderbird:21341): Gtk-CRITICAL **: IA__gtk_clipboard_set_with_data: assertion 'targets != NULL' failed
TypeError: window.content is null
-- Exception object --
*
-- Stack Trace --
KeePassHelper/KeePassHelper.updateDocumentTitle@chrome://keepasshelper/content/KeePassHelper.js:86:13
KeePassHelper/this.setSetDocumentTitle/xulElement.setDocumentTitle@chrome://keepasshelper/content/KeePassHelper.js:249:17
openTab@chrome://messenger/content/tabmail.xml:581:13
doSearch@chrome://messenger/content/search.xml:250:15
onxblkeypress@chrome://messenger/content/search.xml:44:9
sogoWebDAV.prototype._sendHTTPRequest@chrome://inverse-library/content/sogoWebDAV.js:209:28
sogoWebDAV.prototype.load@chrome://inverse-library/content/sogoWebDAV.js:360:13
sogoWebDAV.prototype.propfind@chrome://inverse-library/content/sogoWebDAV.js:427:9
GroupDavSynchronizer.prototype._fetchCardETag@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:490:9
GroupDavSynchronizer.prototype.onCardUploadComplete@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:503:24
GroupDavSynchronizer.prototype.onDAVQueryComplete@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:389:13
sogoWebDAV.prototype._handleHTTPResponse@chrome://inverse-library/content/sogoWebDAV.js:302:17
sogoWebDAV.prototype._sendHTTPRequest/listener.onStreamComplete@chrome://inverse-library/content/sogoWebDAV.js:226:21
sogoWebDAV.prototype._sendHTTPRequest@chrome://inverse-library/content/sogoWebDAV.js:209:28
sogoWebDAV.prototype.load@chrome://inverse-library/content/sogoWebDAV.js:360:13
sogoWebDAV.prototype.propfind@chrome://inverse-library/content/sogoWebDAV.js:427:9
GroupDavSynchronizer.prototype._fetchCardETag@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:490:9
GroupDavSynchronizer.prototype.onCardUploadComplete@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:503:24
GroupDavSynchronizer.prototype.onDAVQueryComplete@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:389:13
sogoWebDAV.prototype._handleHTTPResponse@chrome://inverse-library/content/sogoWebDAV.js:302:17
sogoWebDAV.prototype._sendHTTPRequest/listener.onStreamComplete@chrome://inverse-library/content/sogoWebDAV.js:226:21
{snip portion which repeats many more times}
TypeError: window.content is null
-- Exception object --
*
-- Stack Trace --
KeePassHelper/KeePassHelper.updateDocumentTitle@chrome://keepasshelper/content/KeePassHelper.js:86:13
KeePassHelper/this.setSetDocumentTitle/xulElement.setDocumentTitle@chrome://keepasshelper/content/KeePassHelper.js:249:17
openTab@chrome://messenger/content/tabmail.xml:581:13
doSearch@chrome://messenger/content/search.xml:250:15
onxblkeypress@chrome://messenger/content/search.xml:44:9
sogoWebDAV.prototype._sendHTTPRequest@chrome://inverse-library/content/sogoWebDAV.js:209:28
sogoWebDAV.prototype.load@chrome://inverse-library/content/sogoWebDAV.js:360:13
sogoWebDAV.prototype.propfind@chrome://inverse-library/content/sogoWebDAV.js:427:9
GroupDavSynchronizer.prototype._fetchCardETag@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:490:9
GroupDavSynchronizer.prototype.onCardUploadComplete@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:503:24
GroupDavSynchronizer.prototype.onDAVQueryComplete@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:389:13
sogoWebDAV.prototype._handleHTTPResponse@chrome://inverse-library/content/sogoWebDAV.js:302:17
sogoWebDAV.prototype._sendHTTPRequest/listener.onStreamComplete@chrome://inverse-library/content/sogoWebDAV.js:226:21
sogoWebDAV.prototype._sendHTTPRequest@chrome://inverse-library/content/sogoWebDAV.js:209:28
sogoWebDAV.prototype.load@chrome://inverse-library/content/sogoWebDAV.js:360:13
sogoWebDAV.prototype.propfind@chrome://inverse-library/content/sogoWebDAV.js:427:9
GroupDavSynchronizer.prototype._fetchCardETag@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:490:9
GroupDavSynchronizer.prototype.onCardUploadComplete@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:503:24
GroupDavSynchronizer.prototype.onDAVQueryComplete@chrome://sogo-connector/content/general/sync.addressbook.groupdav.js:389:13
sogoWebDAV.prototype._handleHTTPResponse@chrome://inverse-library/content/sogoWebDAV.js:302:17
sogoWebDAV.prototype._sendHTTPRequest/listener.onStreamComplete@chrome://inverse-library/content/sogoWebDAV.js:226:21
{snip portion which repeats many more times}

(thunderbird:21341): Gtk-CRITICAL **: IA__gtk_clipboard_set_with_data: assertion 'targets != NULL' failed

(thunderbird:21341): Gtk-CRITICAL **: IA__gtk_clipboard_set_with_data: assertion 'targets != NULL' failed
console.error: antidote: 
console.error: antidote: 

(thunderbird:21341): Gtk-CRITICAL **: IA__gtk_clipboard_set_with_data: assertion 'targets != NULL' failed
^C
(Reporter)

Comment 1

3 years ago
I also got the following. Not sure how to pull up more debugging info? GDB intimidates me.

$ thunderbird 

(process:22137): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
[calBackendLoader] Using libical backend at /home/macho/.thunderbird/macho.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libical-manifest
Segmentation fault

Comment 2

3 years ago
Can you retest this with all extensions disabled? If that works then, just enable Lightning and recheck. The only Lightning related message I see in your log excerpt is

> [calBackendLoader] Using libical backend at /home/macho/.thunderbird/macho.default/extensions
> /{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libical-manifest

which is no error but just a notification.

If everything is still fine then, you should test with one additional addon enabled iterating on the remaining addons to identify the suspicious one.
Flags: needinfo?(macho)
(Reporter)

Comment 3

3 years ago
I had a very large (~5k entries) set of contacts, and since I pared it down the problem is gone. I'll open a new bug if this recurs later.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(macho)
Resolution: --- → INVALID

Comment 4

3 years ago
(In reply to Macho Philipovich from comment #3)
> I had a very large (~5k entries) set of contacts, and since I pared it down
> the problem is gone. I'll open a new bug if this recurs later.

Were there also duplicate contacts?
(Sometimes these sync products cause duplicates)
Severity: normal → critical
Keywords: hang, perf
You need to log in before you can comment on or make changes to this bug.