Back in browser doesn't give focus to last visited link

VERIFIED DUPLICATE of bug 36539

Status

()

defect
VERIFIED DUPLICATE of bug 36539
18 years ago
a month ago

People

(Reporter: kinmoz, Assigned: bryner)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Got this bug report/RFE, from cga@gavron.org, off the
netscape.public.mozilla.unix newsgroup. People on IRC said bryner works with
tab-focus in the browser content area, so starting with him

Here's the original posting:

---- cga@gavron.org Wrote:

Hello,

The more I use Mozilla the more I like it. I just wish this NG was more active
so I could get more interaction with the *nix/moz community.

Now, I just noticed that when you use the browser to research some problem or
other you often end up with a web page that is thankfully all text with a large
numbers of links - e.g. you do a Google search and end up with a bunch of
threads from a mailing list..

In these circumstances I tend to tab down to the first link and hit <enter> read
the message use Alt+arrow to go back to the thread index ready to read the next
thread.

For some reason, the 'focus' is sent back to the first link on the page rather
than staying on the last viewed link.. I think that the focus should stay on the
last visited link - that's the way it's done in Microsoft's IE I believe - so
that the user can hit Tab just once to go to the next link.. hit <enter>.. etc..
and be done with the entire thread with minimal inconvenience.

This may seem minor but if you have ever looked for answers to a tricky problem
and doing this kind of detective work for hours on end, having a quick
comfortable way to navigate the links via the keyboard makes a huge difference
to your experience.

I am unsure where I could report this via a bug report or an enhancement request.

All hints much appreciated.

Thanks,
Chris.

Comment 1

18 years ago
Cc Aaron since it affects accessibility/key binding.

Comment 2

18 years ago
Bryner, isn't this a DUP of another bug you had to future?
(Assignee)

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 36539 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: madhur → rakeshmishra

Updated

17 years ago
QA Contact: rakeshmishra → trix
Status: RESOLVED → VERIFIED
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.