EVENTLOOP_UI_{LAG,ACTIVITY}_EXP_MS needs to become an "exceptional case" in histogram.py

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
5 days ago

People

(Reporter: chutten, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
With bug 1198196, we needed to add some special-casing in the server pipeline so that queries against EVENTLOOP_UI_{LAG,ACTIVITY}_EXP_MS histograms don't explode.

How it's been described to me: If you ask for a histogram that isn't in the data, we shouldn't fail because not all samples will have all histograms. If you ask for a histogram that _is_ in the data but whose definition is missing, we explode because it ought to be defined someplace.

bug 1198196 ran afoul of it by taking away a definition from a version where pings still contained data.

Steps to reproduce:
0) Spin up a cluster
1)
pings = get_pings(sc, app="Firefox", channel="nightly", version="45.0a1", fraction=0.01)
subset = get_pings_properties(pings, ["clientId",
                                      "environment/system/os/name",
                                      "payload/histograms/EVENTLOOP_UI_ACTIVITY_EXP_MS",
                                      "payload/histograms/EVENTLOOP_UI_LAG_EXP_MS",
                                      "payload/histograms/GOBBLEDYGOOK",
                                      "payload/simpleMeasurements/firstPaint"])
subset.count()

It'll throw a "KeyError: 'EVENTLOOP_UI_LAG_EXP_MS'"
I have landed the required changes in new-dev. The current t.m.o dashboard is based on the data produced in the old-dev IAM account though. Once 1220262 is fixed, the dashboard will switch over to the new-dev account.
Depends on: 1220262
No longer depends on: 1228308
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

5 days ago
Product: Cloud Services → Cloud Services Graveyard
You need to log in before you can comment on or make changes to this bug.