Closed Bug 1226401 Opened 6 years ago Closed 6 years ago

bad performance with x64 build on Windows when using multiple windows with HWA HW-acceleration enabled

Categories

(Core :: Graphics, defect)

45 Branch
x86_64
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s - ---

People

(Reporter: aney91, Unassigned)

References

Details

(Keywords: perf, Whiteboard: gfx-noted)

Attachments

(2 files)

Two windows at the same time are unusable with x64 build of Nightly 45 on Windows 10 x64.
You can also notice a significant frame rate drop of YouTube videos while typing something into the search bar when using only one window.
With layers.acceleration.disabled=enabled everything works just fine.

I can't reproduce it on x86 build of Firefox (even with same profile) so I guess it's x64 specific.
Blocks: e10s
Have you tested without e10s enabled?
Flags: needinfo?(aney91)
My bad, it doesn't seem to be related to e10s.
I can even see this issue on Firefox 42 win64 (release channel) with a completely clean profile.
No longer blocks: e10s
Flags: needinfo?(aney91)
tracking-e10s: --- → -
Component: General → Graphics
Product: Firefox → Core
Summary: [e10s] bad performance with x64 build on Windows when using multiple windows with HW-acceleration enabled → bad performance with x64 build on Windows when using multiple windows with HW-acceleration enabled
Whiteboard: gfx-noted
As I wrote in #1222821 which is possibly a duplicate, this problem seems to be present on Linux as well. (check out that bug's description for a more detailed description of the experience on my side of this issue)
Keywords: perf
Summary: bad performance with x64 build on Windows when using multiple windows with HW-acceleration enabled → bad performance with x64 build on Windows when using multiple windows with HWA HW-acceleration enabled
CC :benwa, in case it's related to D3D9 performance badness (although, that is E10S only, and this isn't.)
What's the latest news on this bug?
Is the graphics section of your about:support different in x86 vs x64?
Flags: needinfo?(aney91)
The issue is still the same on todays nightly.
The graphics section is exactly the same. In fact the only difference on about:support is the user agent string.
Flags: needinfo?(aney91)
(In reply to Emanuel H. from comment #8)
> The issue is still the same on todays nightly.
> The graphics section is exactly the same. In fact the only difference on
> about:support is the user agent string.

Can you post the contents?
Flags: needinfo?(aney91)
This is the full about:support content from todays nightly 47 (win64 - 20160203)
Flags: needinfo?(aney91)
I can't reproduce this issue any more. x64 build is working perfectly fine now on all channels and even on the 20160203 nightly (where I definitely could see the issue before).
I think the Geforce driver was at fault.
The last faulty driver I know was 10.18.13.6175. Now I have 10.18.13.6510 installed.
As nobody else had confirmed this issue I'm closing this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.