Closed Bug 1226438 Opened 4 years ago Closed 4 years ago

Home screen can be positioned half way between home screen and Pinned Pages screen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P1)

defect

Tracking

(firefox44 affected)

RESOLVED DUPLICATE of bug 1219391
Tracking Status
firefox44 --- affected

People

(Reporter: cpeterson, Unassigned)

Details

(Keywords: foxfood, polish, Whiteboard: [systemsfe])

Attachments

(1 file)

STR:
1. On the home screen, slowly drag LTR to the Pinned Pages screen.
2. Stop dragging when the two "which screen are you on" circles at the top of the screen switch from highlighting the left circle to the right circle. The home screen's vertical scroll bar will be positioned about 30% from the left side of the display.

RESULT:
The screen is positioned between the home screen and Pinned Pages screen without automatically sliding to one or the other.

Also, the home screen icons can still be scrolled vertically when simultaneously swiping horizontally between the home screen and Pinned Pages screen. This feels strange because scroll a page in the browser will lock the scroll axis vertically or horizontally after you start scrolling one way or the other.
Attached image 2015-11-19-16-14-46.png
Here is a screenshot.
It is also unexpected that the Pinned Pages screen can't be scrolled vertically even though there are dotted pin boxes shown cut off on the bottom of the screen (as shown in the attached screenshot).
There are a lot of bugs that have only recently been uplifted to b2g44 around this - can you reproduce this on master gecko?
Flags: needinfo?(cpeterson)
I can't test because I only have a Foxfood phone. I don't have a device running master.
Flags: needinfo?(cpeterson)
Keywords: polish
Priority: -- → P1
Whiteboard: [systemsfe]
Well, I can't reproduce this, so I'm going to assume it's a dupe of bug 1219391.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1219391
You need to log in before you can comment on or make changes to this bug.