Convert android/all/ to the same format as desktop uses

VERIFIED FIXED

Status

www.mozilla.org
Pages & Content
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: nthomas, Assigned: kohei)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1927753] , URL)

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

2 years ago
We should convert this to the format at 
  https://www.mozilla.org/en-US/firefox/all/
ie a table with locales in rows, and columns for each platform. These should use bouncer links, therefore absolving the user from browsing the ftp server.

Note that we have single-locale builds for the two flavours of arm, but only en-US for android-x86. All three build targets have a multi-locale build too.

While helping users, this also helps RelEng, because we want to deprecate https://ftp.mozilla.org/pub/mobile/releases/latest/
Best way for us to do this is if these Android builds are in product-details[0]. If the data is already in ship-it, it should be easy(er) (as of a few days ago) to add a firefox_android.json (or something) to https://product-details.mozilla.org. If that were to exist and be kept updated we could easily generate this page in the same way we do all of the others. If we don't do this then I'm not sure how we'll keep up with changes to which languages are available for what builds like we do for desktop.
(Reporter)

Comment 2

2 years ago
How about we take a baby step and pull version out of 
  http://viewvc.svn.mozilla.org/vc/libs/product-details/json/mobile_details.json?revision=149809&view=co
then link to
  https://archive.mozilla.org/pub/mobile/releases/<version>/android-api-9/
and friends. This frees RelEng to deprecate mobile/releases/latest/.
(Reporter)

Comment 3

2 years ago
Kohei, is comment #2 easy ?
Flags: needinfo?(kohei.yoshino)
(Assignee)

Comment 4

2 years ago
As :pmac said, it would be nice to have the Android supported locale list in Ship-It, since the legacy product-details on SVN will retire soon AFAIK. Anyway converting the list format should not be difficult.
Flags: needinfo?(kohei.yoshino)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1235623
(Assignee)

Updated

2 years ago
Locale: en-US / English (United States)
Whiteboard: [kb=1927753]

Comment 6

2 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/4a7caf0d9c8347bdf05045a43d1dee5d7890367b
Bug 1226476 - Convert android/all/ to the same format as desktop uses

Replaced old links with bouncer links.

https://github.com/mozilla/bedrock/commit/2ebda93e695995c1687624a4faed5b40c8191168
Merge pull request #3722 from tieu/tieu-bouncer-links

Bug 1226476 - Convert android/all/ to the same format as desktop uses

Updated

2 years ago
Duplicate of this bug: 1236095

Comment 8

2 years ago
The commit in comment #6 is now in production (https://www.mozilla.org/en-US/firefox/android/all/) and the links there are working for me. Thanks :vtieu!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

2 years ago
I think this bug is not fixed yet. What requested here is adding links to all locales like the current /firefox/all/ page.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

2 years ago
Taking.
Assignee: nobody → kohei.yoshino
Status: REOPENED → ASSIGNED
(Assignee)

Comment 11

2 years ago
Created attachment 8703454 [details]
Sneak Peek

Comment 12

2 years ago
Comment on attachment 8703454 [details]
Sneak Peek

Oh wow that looks good. Can't wait to see the finished page.
(Assignee)

Comment 13

2 years ago
(In reply to Nick Thomas [:nthomas] (away Dec 21-Jan 24) from comment #0)
> Note that we have single-locale builds for the two flavours of arm, but only
> en-US for android-x86. All three build targets have a multi-locale build too.

I'm aware of this, BTW. The sneak peek is wrong.
(Assignee)

Comment 14

2 years ago
Created attachment 8703553 [details]
Updated screenshot
(Assignee)

Updated

2 years ago
Attachment #8703454 - Attachment is obsolete: true
(Assignee)

Comment 15

2 years ago
Created attachment 8703554 [details] [review]
pull request

This is based on the current product-details info. We may have to update the code when migrating to Ship-It.

Comment 16

2 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/43aa213a15a23a740b93d50e7d999b1340c0e7d9
Fix Bug 1226476 - Convert android/all/ to the same format as desktop uses

https://github.com/mozilla/bedrock/commit/60830de341c2dcb92ecb58d7b7ef2ae9c15cf598
Merge pull request #3728 from kyoshino/bug-1226476-android-all

Fix Bug 1226476 - Convert android/all/ to the same format as desktop uses

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED

Comment 17

2 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/98d6654326dfd8ae25b126d96c924cc68433f9f3
Revert "Fix Bug 1226476 - Convert android/all/ to the same format as desktop uses"

https://github.com/mozilla/bedrock/commit/00e9e565e8e679daa1cf13f9ca0442d1f925314f
Merge pull request #3778 from mozilla/revert-3728-bug-1226476-android-all

Revert "Fix Bug 1226476 - Convert android/all/ to the same format as desktop uses"
(Assignee)

Comment 18

2 years ago
My PR broke the /thunderbird/all/ page. Will try again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 19

2 years ago
(In reply to Kohei Yoshino [:kohei] from comment #18)
> My PR broke the /thunderbird/all/ page. Will try again.

To clarify, /thunderbird/all/ was never broken in production: while this was merged to master it never made it to production because our functional test suite caught the issue. The /firefox/all/ and /android/all pages were both checked manually during the review process, but we do not yet run our functional test suite against PRs automatically, and will need to make some improvements to our CI infrastructure before we begin doing so.
(Assignee)

Comment 20

2 years ago
Created attachment 8708154 [details] [review]
pull request, v2
Attachment #8703554 - Attachment is obsolete: true

Comment 21

2 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/4051c98f7a26ae1d3cb1f7de9b5e8511c38fed4b
Fix Bug 1226476 - Convert android/all/ to the same format as desktop uses

https://github.com/mozilla/bedrock/commit/e3f844ae8bb58aed6971db7316f2b2fd6e6b02c8
Merge pull request #3780 from kyoshino/bug-1226476-android-all

Fix Bug 1226476 - Convert android/all/ to the same format as desktop uses

Updated

2 years ago
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 22

2 years ago
Finally the pages with the new format are live:
https://www.mozilla.org/en-US/firefox/android/all/
https://www.mozilla.org/en-US/firefox/android/beta/all/
Status: RESOLVED → VERIFIED

Comment 23

2 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/6aa5d1e60c5eb001ee9c1ca068b990dc6bfe6104
Add RewriteRule for /firefox/android/beta/all/

Fix the intermittent 404. Follow up #3780. Part of Bug 1226476.
(Assignee)

Comment 24

2 years ago
Created attachment 8711890 [details]
Source PSD file of Android download icons
(Reporter)

Comment 25

2 years ago
Looks great, thank you everyone.
(Assignee)

Comment 26

2 years ago
Somehow the page title of https://www.mozilla.org/en-US/firefox/android/beta/all/ contains Cyrillic characters, saying Бета instead of Beta. I'll figure out what's wrong with it.
You need to log in before you can comment on or make changes to this bug.