[TV 2.5][Browser] Occasionally failed to stop loading a website

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: cynthiatang, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.6?, b2g-v2.5 wontfix, b2g-master affected)

Details

(Whiteboard: [ft:conndevices])

(Reporter)

Description

3 years ago
Branch master
Commit ffaade435bb9c3005fd6c9b7ee1cd17b90e08cbf
Merge: a73d6ac 3cf2386
Author: evelynhung <jj.evelyn@gmail.com>
Date:   Thu Nov 19 11:07:43 2015 +0800

STR:
1. Launch Browser App
2. Go to moztrap.mozilla.org
3. Move cursor to "x"(Stop loading) icon and Press OK

Actual: 
 - It will go to moztrap.mozilla.org

Expected:
 - Stop loading
 - X will change back to Refresh icon
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=TV Browser]

Comment 1

3 years ago
Hi Dan,
Over to you and feel free to reassign to YiFan if you like.
Assignee: nobody → dhuang
blocking-b2g: --- → 2.5+
Flags: needinfo?(yliao)
Flags: needinfo?(dhuang)

Updated

3 years ago
Assignee: dhuang → yliao
Flags: needinfo?(yliao)
The issue happens occasionally when pressing the X button while loading a website. The occurrence of this bug on a TV is rare since using a remote control for the steps to reproduce it takes pretty long time. After offline discussion we suggest to move this to 2.6.
Assignee: yliao → nobody
blocking-b2g: 2.5+ → 2.6?
Flags: needinfo?(dhuang)
Priority: P1 → P3
Summary: [TV 2.5][Browser] Failed to stop loading a website → [TV 2.5][Browser] Occasionally failed to stop loading a website

Updated

3 years ago
status-b2g-v2.5: --- → wontfix
status-b2g-master: --- → affected

Comment 3

3 years ago
I suspect this is not a Gaia issue. What Gaia did is call an API to stop loading.

Comment 4

3 years ago
Hi Mike,
Could you help to test again on latest build whether it's still happening?
Thanks
Flags: needinfo?(mlien)

Updated

3 years ago
Blocks: 1253245

Comment 5

3 years ago
Verify the latest simulator build, the situation is like comment 0's expected result: it will stop loading with "X" icon be changed to reload icon

Build information:
gaia:
https://github.com/mozilla-b2g/gaia/commit/1d23360f728942ca0ee66249cb15442c6f398c65
gecko:
https://hg.mozilla.org/mozilla-central/rev/68c0b7d6f16ce5bb023e08050102b5f2fe4aacd8
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mlien)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.