Closed Bug 1226607 Opened 9 years ago Closed 9 years ago

When there's no converstions - the UX isn't matching new user journey (see URL)

Categories

(Hello (Loop) :: Client, defect, P2)

x86_64
Linux
defect

Tracking

(firefox46 verified)

VERIFIED FIXED
Iteration:
46.1 - Dec 28
Tracking Status
firefox46 --- verified

People

(Reporter: pauly, Assigned: crafuse)

References

()

Details

(Whiteboard: [web experience][new user journey])

Attachments

(6 files, 1 obsolete file)

Attached image beta 43.png
FF 43b5, 45.0a1 (2015-11-20) Ubuntu 14.04 x64
STR:
1. Open the Hello panel
2. Make sure there are no conversations in list

Actual results:
"N" character from the "No conversation yet" is cropped

Notes: This is Linux specific, doesn't reproduce on Mac, Win.
Selecting the entire word with mouse makes the character to be completely displayed until I close/reopen the Hello panel.
This is more prominent in FF 43, compared to FF 45.
Attached image nightly 45.png
First bad nightly: 2015-09-13
Blocks: 1196499
UX mismatch in 45 from what it should be.  Will let it go in 43 as it's changing drastically.

http://people.mozilla.org/~sfranks/Hello/Firefox%20Hello%20Link%20Generator.png
Rank: 25
Priority: -- → P2
Summary: [Linux] "N" character from the "No conversation yet" text is cropped → When there's no converstions - the UX isn't matching new user journey (see URL)
Whiteboard: [web experience, new user journey]
Whiteboard: [web experience, new user journey] → [web experience, new user journey][triage]
Assignee: nobody → crafuse
Status: NEW → ASSIGNED
Just needed to add a height to the paragraph container and may have been causing some font scaling.
Attachment #8703037 - Flags: review?(standard8)
Attachment #8703037 - Flags: review?(edilee)
Attachment #8703037 - Flags: review?(dcritchley)
Comment on attachment 8703037 [details] [review]
Link to Github pull-request: https://github.com/mozilla/loop/pull/36

The pull request doesn't seem to do what this bug is requesting of matching the new user journey, which doesn't refer to conversations.
Attachment #8703037 - Flags: review?(standard8)
Attachment #8703037 - Flags: review?(edilee)
Attachment #8703037 - Flags: review?(dcritchley)
Attachment #8703037 - Flags: review-
I believe this is the relevant portion of the linked url as per bug title: http://people.mozilla.org/~sfranks/Hello/Firefox%20Hello%20Link%20Generator.png
Comment on attachment 8703037 [details] [review]
Link to Github pull-request: https://github.com/mozilla/loop/pull/36

Removed view, CSS, tests and image.
Attachment #8703037 - Flags: review- → review?(edilee)
Can you attach a screenshot either here or in github? The pull request seems like it wouldn't match the requested design.
Attached image Empty Conversations Panel Content (obsolete) —
Added screen shot of no conversations shown in panel.
Attachment #8703176 - Flags: review?(edilee)
The panel resize will be completed in Bug 1234183 as this will break functionality.
Removal of the no conversations message view was completed in this bug.
Created Bug 1236082 for footer email address display.
Comment on attachment 8703176 [details]
Empty Conversations Panel Content

This bug should focus on removing/not-showing content and bug 1234183 should focus on sizing. So, the fix here should result in not having the line or "Recently browsed" shown.
Attachment #8703176 - Flags: review?(edilee) → review-
Depends on: 1236082
Depends on: 1234183
Whiteboard: [web experience, new user journey][triage] → [web experience][new user journey]
Attachment #8703176 - Attachment is obsolete: true
Attached image noRoomsShown.png
Does not render the top border, rooms title and rooms list if there are no conversation rooms.
Attachment #8703880 - Flags: review+
Attachment #8703880 - Flags: review+ → review?(edilee)
Comment on attachment 8703037 [details] [review]
Link to Github pull-request: https://github.com/mozilla/loop/pull/36

Added some minor issues for naming and spacing. Bigger question of why split it into multiple methods instead of a single _renderRoomsList helper.
Attachment #8703037 - Flags: review?(edilee) → feedback+
Comment on attachment 8703880 [details]
noRoomsShown.png

Looks like UI showcase for panels might have been broken by bug 1219158?
Attachment #8703880 - Flags: review?(edilee)
(In reply to Ed Lee :Mardak from comment #15)
> Looks like UI showcase for panels might have been broken by bug 1219158?
Fixed by bug 1236917.
Comment on attachment 8703037 [details] [review]
Link to Github pull-request: https://github.com/mozilla/loop/pull/36

Due to eslint restrictions else can not be used in a function return, I assume it returns void if not returned.  Renamed the functions and fixed indentation of rooms list function.  I could not use the code in the same render function as it would break as soon as I added any conditionals.
Attachment #8703037 - Flags: review?(edilee)
(In reply to Chris Rafuse :crafuse from comment #17)
> Due to eslint restrictions else can not be used in a function return, I
> assume it returns void if not returned.
If you're running into no-else-return, then you should have done `if () return null; return <>` instead of `if () return null; else return <>;

By omitting the return, you're implicitly returning undefined.
(In reply to Chris Rafuse :crafuse from comment #17)
> I could not use the code in the same render function as it would break as soon as I added any conditionals.
How were you adding conditionals? The tertiary {length ? <h1></h1> : null} should work. See https://github.com/mozilla/loop/blob/master/add-on/panels/js/panel.jsx#L490
See comment 19 / PR comment https://github.com/mozilla/loop/pull/36#discussion_r49051911 before addressing other issues as putting the _renders inline avoids fixing some other issues.
Flags: needinfo?(crafuse)
Comment on attachment 8703037 [details] [review]
Link to Github pull-request: https://github.com/mozilla/loop/pull/36

r=Mardak with a note that the UI is slightly changed for the loading screen as there's no border under the button.
Flags: needinfo?(crafuse)
Attachment #8703037 - Flags: review?(edilee) → review+
https://github.com/mozilla/loop/commit/cb2cabe52a94fdde46dcc4f6bd31955ce7110a50
Status: ASSIGNED → RESOLVED
Iteration: --- → 46.1 - Dec 28
Closed: 9 years ago
Resolution: --- → FIXED
No text when the list is empty in the new UI.
Verified fixed FF 46.0a1 (2016-01-20), Ubuntu 14.04.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: