test_cost_control_reset_wifi.py : TimeoutException: TimeoutException: Timed out after 10.2 seconds

RESOLVED DUPLICATE of bug 1226636

Status

Firefox OS
Gaia::UI Tests
RESOLVED DUPLICATE of bug 1226636
2 years ago
2 years ago

People

(Reporter: MaxIvanov, Assigned: Martijn Wargers (dead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Description: Test case fails with "TimeoutException"

Steps:
1. Update a flame device to 20151120030231
2. Run this test case http://lxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/cost_control/test_cost_control_reset_wifi.py

Actual result:
"TimeoutException"

Expected result:
Test completes successfully.

Repro Rate: Reproduced via Jenkins adhoc (0/5 passing)
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/354/HTML_Report/

Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-1.0.0-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/cost_control/test_cost_control_reset_wifi.py", line 27, in test_cost_control_reset_wifi
cost_control.disable_mobile_data_tracking()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/cost_control/app.py", line 36, in disable_mobile_data_tracking
self._mobile_tracking_switch.disable()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/form_controls/binarycontrol.py", line 31, in disable
self._toggle_and_verify_state(final_state=False)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/form_controls/binarycontrol.py", line 38, in _toggle_and_verify_state
self.wait_to_be_ready()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/form_controls/binarycontrol.py", line 35, in wait_to_be_ready
Wait(self.marionette).until(lambda m: self.is_enabled)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-1.0.0-py2.7.egg/marionette_driver/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 10.2 seconds
(Assignee)

Updated

2 years ago
Assignee: nobody → martijn.martijn
Blocks: 1221630
(Assignee)

Comment 1

2 years ago
Will be fixed by bug 1226636.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226636
You need to log in before you can comment on or make changes to this bug.