Open Bug 12267 Opened 20 years ago Updated 11 years ago

Sidebar grippy & scrollbar drawn twice on toolbar collapse/expand.

Categories

(Core :: XUL, defect, P3)

x86
Other
defect

Tracking

()

REOPENED
Future

People

(Reporter: CodeMachine, Assigned: eric)

Details

(Whiteboard: DO NOT resolve per bug 112534 unless this cannot be reproduced with 1.0.x or 1.1.x builds)

When I expand or collapse a toolbar I notice both the sidebar grippy and the
scroll bar get redrawn twice - first in the wrong place, then in the correct
place.  It should only get redrawn in the correct place once.  This is on a
fairly fast machine so I imagine you should be able to see it.

Build id is 1999081911.
Assignee: trudelle → evaughan
reassigning to evaughan to check for regression with GFX versions of these
widgets.
Status: NEW → ASSIGNED
Target Milestone: M11
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
This is not fixed on build 1999091409.  I've noticed it only happens on the
toolbars above the NGLayout widget though.
This also seems to happen when you maximise the window.
Hmm, I've noticed this "redraw twice" behaviour a bit more on closer inspection.
 For example, open and closing the sidebar causes the scroll bar on the right to
be redrawn twice.  This time it's horizontally out of whack because the
horizontal, rather than the vertical space is changing.
Clearing FIXED resolution due to reopen of this bug.
Resolution: FIXED → ---
Target Milestone: M11 → M13
i'm having a problem on linux where the sidebar grippy disappears when
the sidebar is open and i mouse over the grippy.it doesn't happen if
the sidebar is closed. The grippy reappears when i close the sidebar
but disappears when i open it again. If i cover the grippy with another
window and then re-expose it, the grippy reappears.

Let me know if this belongs in a seperate bug.
mass-moving all m13 bugs to m14
spam: changing qa contact from ckritzer -> paulmac for xul bugs
Target Milestone: M14 → M15
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL
targeting
Target Milestone: M15 → M16
Target Milestone: M16 → M18
Mass moving M18 bugs to M19
Target Milestone: M18 → M19
spam, open xptoolkit qa contact moving over to jrgm
QA Contact: paulmac → jrgm
mass-moving all bugs to m21 that are not dogfood+ or nsbeta2+ or nsbeta2-
Target Milestone: M19 → M21
(per trudelle). mass-moving all evaughan non-nsbeta3+ bugs to 'Future'
milestone
Target Milestone: M21 → Future
Old bug. Can anyone still reproduce this bug with a Mozilla 1.0.x
or Mozilla 1.1.x build?
Whiteboard: DO NOT resolve per bug 112534 unless this cannot be reproduced with 1.0.x or 1.1.x builds
I have reproduced a similar bug on the 2003080204 nightly build.  When expanding
the sidebar.  The grippy is drawn correctly in it's new expanded position, but
half the grippy is also drawn in it's collapsed position.  I have reproduced
this every time, even after closing the browser, resizing the window.. etc...

Here's the browser/OS ident for my system: 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030802
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.