Media App permissions is not showing on first time launch

RESOLVED INVALID

Status

Firefox OS
Gaia::Camera
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-v2.5 affected, b2g-master affected)

Details

1. flash the device
2. launch camera

Expected: geolocation and app permission for camera use.
Actual: just the geolocation app permission

Note: 
1. going to settings -> permissions only shows the geolocation
2. filed because we can't seem to trigger it going to recording web apps or using other full apps.
3. referring to : https://github.com/mozilla-b2g/gaia/blob/master/apps/system/style/permission_manager/permission_manager.css#L230
Hey Andrew?  Was there a change somewhere along the way?  I was looking into app permissions for a test and then noticed this oddness...
Flags: needinfo?(aosmond)
adding qawanted for branch check
Keywords: qawanted
We don't prompt for camera use in certified apps. That's the expected behavior.

Comment 4

2 years ago
I seeing ONLY geo-location permissions for Aries 2.6, Aries 2.5, Flame 2.5 and Flame 2.2.


Environmental Variables:
Device: Aries 2.6
BuildID: 20151120133504
Gaia: 94a821b49f4dca3f9321cd80e13c44c4a6696952
Gecko: ec628289d8b4ed310463a0729c3e60a7798dfcac
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Aries 2.5
BuildID: 20151120074230
Gaia: b7f130c36588e308784cd1b7c8a28585c9819076
Gecko: 589a9b96c5bc632bcc336d0543442983cc1f61dd
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.6
BuildID: 20151120030231
Gaia: 94a821b49f4dca3f9321cd80e13c44c4a6696952
Gecko: 3835b568092ae3b71adc931d24928670ad7141a7
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (512mb)
BuildID: 20151120032503
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 462d8e9208ea
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
(In reply to [:fabrice] Fabrice Desré from comment #3)
I checked the behavior with a privileged app from the Marketplace[1], and I confirm it: The prompt is displayed on master. Closing this bug as this is by design[2]

[1] https://marketplace.firefox.com/app/photography?src=search
[2] https://dxr.mozilla.org/mozilla-central/rev/abbd213422a560f1180c4ec6e3bf4792c2ea81ba/dom/apps/PermissionsTable.jsm#50
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(aosmond)
Resolution: --- → INVALID
Ok, thanks.  Hrm.  Perhaps the test cases are coded incorrectly on the webapps...
You need to log in before you can comment on or make changes to this bug.