[TV 2.5][Browser] Failed to rename a bookmark when leaving it empty.

RESOLVED DUPLICATE of bug 1226527

Status

P3
normal
RESOLVED DUPLICATE of bug 1226527
3 years ago
3 years ago

People

(Reporter: cynthiatang, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.6?, b2g-v2.5 wontfix, b2g-master affected)

Details

(Whiteboard: [ft:conndevices])

(Reporter)

Description

3 years ago
Branch master
Commit ffaade435bb9c3005fd6c9b7ee1cd17b90e08cbf
Merge: a73d6ac 3cf2386
Author: evelynhung <jj.evelyn@gmail.com>
Date:   Thu Nov 19 11:07:43 2015 +0800

STR:
 1. Launch Browser App
 2. Go to yahoo.com (The title is "Yahoo奇摩")
 3. Go to Bookmarks lists
 4. Select a bookmark
 5. Press Option 
 6. Select Rename 
 7. Empty the name and save it

Actual result: 
 - The title is not empty in Bookmarks list. It is "Yahoo奇摩"
(Reporter)

Updated

3 years ago
Summary: [TV 2.5][Browser] Failed to rename a bookmark to be no name → [TV 2.5][Browser] Failed to rename a bookmark
(Reporter)

Comment 1

3 years ago
Hi Tori, could you please provide the expected result? Thank you
QA Whiteboard: [COM=TV Browser]
Flags: needinfo?(tchen)

Comment 2

3 years ago
When the bookmark title is empty, users should not be able to save it.

Expected result:
- The underline is red
- Show the message "the bookmark name cannot be empty"
- Disable "OK" button
Flags: needinfo?(tchen) → needinfo?(ctang)
(Reporter)

Comment 3

3 years ago
Hi Josh,
Do we have the resource for this issue? Thank you!
Flags: needinfo?(ctang)
(Reporter)

Updated

3 years ago
Flags: needinfo?(jocheng)

Comment 4

3 years ago
Kind of a UI polish. I would say nice-to-have.

Updated

3 years ago
Summary: [TV 2.5][Browser] Failed to rename a bookmark → [TV 2.5][Browser] Failed to rename a bookmark when leaving it empty.

Updated

3 years ago
blocking-b2g: --- → 2.6?

Comment 5

3 years ago
Agree with Evelyn.
status-b2g-v2.5: --- → wontfix
status-b2g-master: --- → affected
Flags: needinfo?(jocheng)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226527
You need to log in before you can comment on or make changes to this bug.