[dogfood]phonebook doesn't work

VERIFIED INVALID

Status

()

Core
HTML: Parser
P3
normal
VERIFIED INVALID
19 years ago
19 years ago

People

(Reporter: Chris McAfee, Assigned: rickg)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+][dogfood] [12/19], URL)

(Reporter)

Description

19 years ago
Linux.  viewer, apprunner.

http://phonebook doesn't work.  I'm trying to look myself up,
I enter "mcafee" in the search text field, hit search.
No content loads, and I get:

Error: Can't load: http://phonebook/dsgw/bin/lang?context=default&file=phone.htm
l (804b0002)

Note, there is an SSL version of phonebook, separate bug
filed for that:  http://bugzilla.mozilla.org/show_bug.cgi?id=8301
(Assignee)

Updated

19 years ago
Assignee: rickg → pollmann
(Assignee)

Comment 1

19 years ago
Eric -- can you take a look. This may be a forms submission problem.
(Reporter)

Comment 2

19 years ago
This is still dead in the water for me.

Comment 3

19 years ago
This may be an https bug as well.  I noticed that the action of the phonebook
form is:

https://dagobah.mcom.com/dsgw/bin/dosearch

I changed it to:

http://pollmann.com/echo.cgi

And the form submitted correctly, and update the results frame, as expected.  To
see this modified version of the phonebook, go to:

http://blueviper/forms/pb
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: pollmann → warren
Status: ASSIGNED → NEW
Component: Parser → Necko
OS: Linux → All
Hardware: PC → All
Summary: phonebook doesn't work → https not working -> phonebook doesn't work

Comment 4

19 years ago
I'd say this was the problem.  Try browsing to this address:
https://dagobah.mcom.com/dsgw/bin/dosearch

In nav, it displays a "Required query/form input is missing" page
In gecko, it does not even update the window.

Not sure who to give thisto, but since this appears to be a networking issue,
I'm reassigning it to warren.
(Reporter)

Comment 5

19 years ago
I'd like to keep SSL out of this bug, per my first comment.

Updated

19 years ago
Assignee: warren → dougt
Target Milestone: M14

Comment 6

19 years ago
Assigned to dougt.
(Reporter)

Updated

19 years ago
Assignee: dougt → warren
Summary: https not working -> phonebook doesn't work → Non-SSL phonebook doesn't work
(Reporter)

Comment 7

19 years ago
I don't see SSL here!  Look at my first comment!
Back to warren, taking SSL out of summary.
Please let me know if I am wrong here.

Comment 8

19 years ago
I have SSL working, and phonebook is still not working. The error I get is
"Invalid or incomplete HTML form date. (missing form data element "mode")

This happens on a submit after http://phonebook loads.

Comment 9

19 years ago
are you seeing any error messages in the output of PSM?  are you seeing the
error -8191?

Comment 10

19 years ago
No, I don't see any error messages.

Updated

19 years ago
Assignee: warren → gagan

Comment 11

19 years ago
Gagan, can you check this one out?

Comment 12

19 years ago
*** Bug 8301 has been marked as a duplicate of this bug. ***

Comment 13

19 years ago
*** Bug 15812 has been marked as a duplicate of this bug. ***

Comment 14

19 years ago
*** Bug 14629 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Whiteboard: [dogfood]

Comment 15

19 years ago
ssl comes and goes. this might be a good thing to have working as a backup.
putting on the dogfood radar.

Comment 16

19 years ago
ssl comes and goes. this might be a good thing to have working as a backup.
putting on the dogfood radar.

Comment 17

19 years ago
using 11/18 builds, phonebook works ok on windows
using 11/19 builds, phonebook crashes upon submitting a name in nspr

libnspr3.so + 0xb37f (0x4012137f)
libpsmcomp.so + 0x5484 (0x411c7484)
libpsmcomp.so + 0x7647 (0x411c9647)
libpsmcomp.so + 0x5b6e (0x411c7b6e)
libnkssl.so + 0x3710 (0x411d6710)
libnspr3.so + 0xb38d (0x4012138d)
libnecko.so + 0xd11e (0x402d811e)
libnecko.so + 0xcd12 (0x402d7d12)
libnecko.so + 0xec9c (0x402d9c9c)
libnecko.so + 0xf0ba (0x402da0b

Comment 18

19 years ago
*** Bug 18617 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Whiteboard: [dogfood] → [dogfood][PDT+]

Comment 19

19 years ago
Using the non-SSL phonebook:

	* crashes on 1999 11.22.09 build on Linux Commercial build
	* does nothing on 1999 11.22.08 Mac OS Commercial build.

Transferring [PDT+] designation of this issue from duplicate bug #18617.

Updated

19 years ago
Assignee: gagan → warren
Status: ASSIGNED → NEW

Comment 20

19 years ago
Assigning to warren since gagan out.

Updated

19 years ago
Whiteboard: [dogfood][PDT+] → [PDT+][dogfood][PDT+]

Comment 21

19 years ago
The phonebook is now point off to a https server during the post.  If you have
the commercial build and version 1.0 of cartman, this site works fine.

Comment 22

19 years ago
So you're saying it works? I guess the problem here is lack of user feedback
for failed urls/protocols, but that's a different bug.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 23

19 years ago
This is no longer a bug.  I can successfully connect with the commercial build.
There is another bug regarding "No warning when mozilla can't connect to
high-encryption site" which is 17697.

Marking this bug as fixed.
(Reporter)

Comment 24

19 years ago
I don't see security mode for this url when using 4.5,
dougt can you explain?

Comment 25

19 years ago
what do you mean a security mode?  The response from the post is a https
redirect.

Updated

19 years ago
Depends on: 20488

Comment 26

19 years ago
This bug is currently blocked by bug 20488.

Updated

19 years ago
Whiteboard: [PDT+][dogfood][PDT+] → [PDT+][dogfood][PDT+] - blocked by 20488

Updated

19 years ago
Depends on: 20372
No longer depends on: 20488
Whiteboard: [PDT+][dogfood][PDT+] - blocked by 20488 → [PDT+][dogfood][PDT+] - blocked by 20372

Comment 27

19 years ago
Bug 20488 marked as a duplicate of 20372.  Changed "Bugs that bug 12269 depends
on" to 20372.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: FIXED → ---

Comment 28

19 years ago
Phonebook is not working on any platform in todays build
1999120609

Updated

19 years ago
Assignee: warren → dougt
Status: REOPENED → NEW

Comment 29

19 years ago
1. I tried http://blueviper/forms/pb with a mozilla build and it worked fine.

2. I tried http://phonebook with a commercial build and cartman crashed on me.
I don't have source, so I can't tell you where.

3. After cartman crashes, if you try to go to another ssl site you hang forever
here:

NTDLL! 77f678df()
KERNEL32! 77f1ced8()
nsPSMComponent::GetControlConnection(nsPSMComponent * const 0x031b30e0,
_CMT_CONTROL * * 0x031b37e0) line 356 + 22 bytes
nsSSLIOLayerConnect(PRFileDesc * 0x030c7940, const PRNetAddr * 0x031b22d0,
unsigned int 0x00000449) line 87 + 25 bytes
PR_Connect(PRFileDesc * 0x030c7940, const PRNetAddr * 0x031b22d0, unsigned int
0x00000449) line 166 + 20 bytes
nsSocketTransport::doConnection(short 0x0000) line 729 + 28 bytes
nsSocketTransport::Process(short 0x0000) line 498 + 13 bytes
nsSocketTransportService::ProcessWorkQ() line 247 + 10 bytes
nsSocketTransportService::Run(nsSocketTransportService * const 0x02ba46c4) line
481 + 11 bytes
nsThread::Main(void * 0x02ba4160) line 83 + 26 bytes
_PR_NativeRunThread(void * 0x02ba5eb0) line 399 + 13 bytes
_threadstartex(void * 0x02ba5e10) line 212 + 13 bytes
KERNEL32! 77f04ee8()

Seems like nsPSMComponent::GetControlConnection should either have a timeout or
attempt to restart cartman, or both.

Reassigning to dougt.

Comment 30

19 years ago
investigating.
Status: NEW → ASSIGNED
Whiteboard: [PDT+][dogfood][PDT+] - blocked by 20372 → [PDT+][dogfood]
(Assignee)

Comment 31

19 years ago
DVeditz: are we making any traction here? Can you get us an estimate for fixing
this?

Comment 32

19 years ago
fix in hand.

Comment 33

19 years ago
does the fix stop the crash?  Using yesterday's build it went off to never never
land when submitting a query but didn't crash...at least in the few minutes we
waited.

Comment 34

19 years ago
Yes, this will fix both the crash and the infinite loop.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 35

19 years ago
I checked in a fix for this.

Comment 36

19 years ago
*** Bug 21088 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 37

19 years ago
Reopening. Search for "unruh" will bring up only one name. On this screen, I
only see my name and the words "view card" - no phone number or other info.

Updated

19 years ago
Resolution: FIXED → ---

Comment 38

19 years ago
Clearing FIXED resolution due to reopen.

Comment 39

19 years ago
cache related?  are form broken again?  changes to ssl/https have been minimal.

Comment 40

19 years ago
I don't think it's Necko-related.  I put a breakpoint in nsHTTPChannel::Open()
and clicked on the phonebook Search button and nothing happened.  No one is
calling the protocol handler to post the form data.

Comment 41

19 years ago
are you using the commercial build?

Comment 42

19 years ago
This is not an SSL or cartman problem.  If I try to go to the following URL,
only the partial page loads:

http://quermia.mcom.com/dsgw/bin/dosearch?context=default&hp=localhost&dn=uid%3
Ddougt%2Cou%3DPeople%2Cdc%3Dnetscape%2Cdc%3Dcom

Comment 43

19 years ago
Whoops! I wasn't using the commercial build.

I tried the non-working URL you cite in your last report.  I found that it
doesn't load on Mozilla, even when the cache is disabled.  Also, I tried loading
that URL using NN4, saved it out to disk and opened the saved version with
Mozilla.  The result was similarly truncated, so I'm guessing this is a
layout/parser problem.

Updated

19 years ago
Assignee: dougt → troy
Status: REOPENED → NEW
Component: Necko → Layout
Summary: Non-SSL phonebook doesn't work → [dogfood]Non-SSL phonebook doesn't work

Comment 44

19 years ago
assign to troy.

Comment 45

19 years ago
*** Bug 21594 has been marked as a duplicate of this bug. ***

Comment 46

19 years ago
there are two bugs here.. one is a parser bug, the other is a phonebook html
bug.  It stops parsing the page at:  "<![if ! IE 5]>"  (this is from their
HTML).  I'm not sure WTF this is supposed to do, but the parser shouldn't bail
here.  I'm also not sure how to file a bug against phonebook :)

Updated

19 years ago
Assignee: troy → rickg
Component: Layout → Parser

Comment 47

19 years ago
Based on pavlov's analysis (thanks pavlov) changing component and re-assigning
to parser (for the parser bug that he mentions)
Summary: [dogfood]Non-SSL phonebook doesn't work → [dogfood]phonebook doesn't work
Not an SSL problem, summary was triggering false matches
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 49

19 years ago
Pavlov -- the parser bug looks trivial. Can you please send me the HTML file
that you used? (With the fragment "<![if ! IE 5]>").
(Assignee)

Comment 50

19 years ago
The problem is fixed in my tree. I'm awaiting a review and approval to check it
in.
(Assignee)

Updated

19 years ago
Whiteboard: [PDT+][dogfood] → [PDT+][dogfood] [12/19]
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 51

19 years ago
Fixed by improvement to parser in dealing with cdata sections.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: FIXED → ---

Comment 52

19 years ago
Searching for names in phonebook no longer produces an error message, but it
also doesn't find the names you search on.  Tried http:// and https:// with same
result.
(tried on linux and Win98 - same result)
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 53

19 years ago
This bug is closed because the problem it describes was fixed (and remains
fixed). I'm closing this again, but doing Jan the favor of opening a new bug
that describes the new problem.
(Reporter)

Comment 54

19 years ago
New bug rick filed is:
http://bugzilla.mozilla.org/show_bug.cgi?id=24317

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 55

19 years ago
Thanks, marking this verified
You need to log in before you can comment on or make changes to this bug.