Closed Bug 12269 Opened 21 years ago Closed 20 years ago

[dogfood]phonebook doesn't work

Categories

(Core :: DOM: HTML Parser, defect, P3)

defect

Tracking

()

VERIFIED INVALID

People

(Reporter: mcafee, Assigned: rickg)

References

()

Details

(Whiteboard: [PDT+][dogfood] [12/19])

Linux.  viewer, apprunner.

http://phonebook doesn't work.  I'm trying to look myself up,
I enter "mcafee" in the search text field, hit search.
No content loads, and I get:

Error: Can't load: http://phonebook/dsgw/bin/lang?context=default&file=phone.htm
l (804b0002)

Note, there is an SSL version of phonebook, separate bug
filed for that:  http://bugzilla.mozilla.org/show_bug.cgi?id=8301
Assignee: rickg → pollmann
Eric -- can you take a look. This may be a forms submission problem.
This is still dead in the water for me.
This may be an https bug as well.  I noticed that the action of the phonebook
form is:

https://dagobah.mcom.com/dsgw/bin/dosearch

I changed it to:

http://pollmann.com/echo.cgi

And the form submitted correctly, and update the results frame, as expected.  To
see this modified version of the phonebook, go to:

http://blueviper/forms/pb
Status: NEW → ASSIGNED
Assignee: pollmann → warren
Status: ASSIGNED → NEW
Component: Parser → Necko
OS: Linux → All
Hardware: PC → All
Summary: phonebook doesn't work → https not working -> phonebook doesn't work
I'd say this was the problem.  Try browsing to this address:
https://dagobah.mcom.com/dsgw/bin/dosearch

In nav, it displays a "Required query/form input is missing" page
In gecko, it does not even update the window.

Not sure who to give thisto, but since this appears to be a networking issue,
I'm reassigning it to warren.
I'd like to keep SSL out of this bug, per my first comment.
Assignee: warren → dougt
Target Milestone: M14
Assigned to dougt.
Assignee: dougt → warren
Summary: https not working -> phonebook doesn't work → Non-SSL phonebook doesn't work
I don't see SSL here!  Look at my first comment!
Back to warren, taking SSL out of summary.
Please let me know if I am wrong here.
I have SSL working, and phonebook is still not working. The error I get is
"Invalid or incomplete HTML form date. (missing form data element "mode")

This happens on a submit after http://phonebook loads.
are you seeing any error messages in the output of PSM?  are you seeing the
error -8191?
No, I don't see any error messages.
Assignee: warren → gagan
Gagan, can you check this one out?
*** Bug 8301 has been marked as a duplicate of this bug. ***
*** Bug 15812 has been marked as a duplicate of this bug. ***
*** Bug 14629 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Whiteboard: [dogfood]
ssl comes and goes. this might be a good thing to have working as a backup.
putting on the dogfood radar.
ssl comes and goes. this might be a good thing to have working as a backup.
putting on the dogfood radar.
using 11/18 builds, phonebook works ok on windows
using 11/19 builds, phonebook crashes upon submitting a name in nspr

libnspr3.so + 0xb37f (0x4012137f)
libpsmcomp.so + 0x5484 (0x411c7484)
libpsmcomp.so + 0x7647 (0x411c9647)
libpsmcomp.so + 0x5b6e (0x411c7b6e)
libnkssl.so + 0x3710 (0x411d6710)
libnspr3.so + 0xb38d (0x4012138d)
libnecko.so + 0xd11e (0x402d811e)
libnecko.so + 0xcd12 (0x402d7d12)
libnecko.so + 0xec9c (0x402d9c9c)
libnecko.so + 0xf0ba (0x402da0b
*** Bug 18617 has been marked as a duplicate of this bug. ***
Whiteboard: [dogfood] → [dogfood][PDT+]
Using the non-SSL phonebook:

	* crashes on 1999 11.22.09 build on Linux Commercial build
	* does nothing on 1999 11.22.08 Mac OS Commercial build.

Transferring [PDT+] designation of this issue from duplicate bug #18617.
Assignee: gagan → warren
Status: ASSIGNED → NEW
Assigning to warren since gagan out.
Whiteboard: [dogfood][PDT+] → [PDT+][dogfood][PDT+]
The phonebook is now point off to a https server during the post.  If you have
the commercial build and version 1.0 of cartman, this site works fine.
So you're saying it works? I guess the problem here is lack of user feedback
for failed urls/protocols, but that's a different bug.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
This is no longer a bug.  I can successfully connect with the commercial build.
There is another bug regarding "No warning when mozilla can't connect to
high-encryption site" which is 17697.

Marking this bug as fixed.
I don't see security mode for this url when using 4.5,
dougt can you explain?
what do you mean a security mode?  The response from the post is a https
redirect.
Depends on: 20488
This bug is currently blocked by bug 20488.
Whiteboard: [PDT+][dogfood][PDT+] → [PDT+][dogfood][PDT+] - blocked by 20488
Depends on: 20372
No longer depends on: 20488
Whiteboard: [PDT+][dogfood][PDT+] - blocked by 20488 → [PDT+][dogfood][PDT+] - blocked by 20372
Bug 20488 marked as a duplicate of 20372.  Changed "Bugs that bug 12269 depends
on" to 20372.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Phonebook is not working on any platform in todays build
1999120609
Assignee: warren → dougt
Status: REOPENED → NEW
1. I tried http://blueviper/forms/pb with a mozilla build and it worked fine.

2. I tried http://phonebook with a commercial build and cartman crashed on me.
I don't have source, so I can't tell you where.

3. After cartman crashes, if you try to go to another ssl site you hang forever
here:

NTDLL! 77f678df()
KERNEL32! 77f1ced8()
nsPSMComponent::GetControlConnection(nsPSMComponent * const 0x031b30e0,
_CMT_CONTROL * * 0x031b37e0) line 356 + 22 bytes
nsSSLIOLayerConnect(PRFileDesc * 0x030c7940, const PRNetAddr * 0x031b22d0,
unsigned int 0x00000449) line 87 + 25 bytes
PR_Connect(PRFileDesc * 0x030c7940, const PRNetAddr * 0x031b22d0, unsigned int
0x00000449) line 166 + 20 bytes
nsSocketTransport::doConnection(short 0x0000) line 729 + 28 bytes
nsSocketTransport::Process(short 0x0000) line 498 + 13 bytes
nsSocketTransportService::ProcessWorkQ() line 247 + 10 bytes
nsSocketTransportService::Run(nsSocketTransportService * const 0x02ba46c4) line
481 + 11 bytes
nsThread::Main(void * 0x02ba4160) line 83 + 26 bytes
_PR_NativeRunThread(void * 0x02ba5eb0) line 399 + 13 bytes
_threadstartex(void * 0x02ba5e10) line 212 + 13 bytes
KERNEL32! 77f04ee8()

Seems like nsPSMComponent::GetControlConnection should either have a timeout or
attempt to restart cartman, or both.

Reassigning to dougt.
investigating.
Status: NEW → ASSIGNED
Whiteboard: [PDT+][dogfood][PDT+] - blocked by 20372 → [PDT+][dogfood]
DVeditz: are we making any traction here? Can you get us an estimate for fixing
this?
fix in hand.
does the fix stop the crash?  Using yesterday's build it went off to never never
land when submitting a query but didn't crash...at least in the few minutes we
waited.
Yes, this will fix both the crash and the infinite loop.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
I checked in a fix for this.
*** Bug 21088 has been marked as a duplicate of this bug. ***
Status: RESOLVED → REOPENED
Reopening. Search for "unruh" will bring up only one name. On this screen, I
only see my name and the words "view card" - no phone number or other info.
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
cache related?  are form broken again?  changes to ssl/https have been minimal.
I don't think it's Necko-related.  I put a breakpoint in nsHTTPChannel::Open()
and clicked on the phonebook Search button and nothing happened.  No one is
calling the protocol handler to post the form data.
are you using the commercial build?
This is not an SSL or cartman problem.  If I try to go to the following URL,
only the partial page loads:

http://quermia.mcom.com/dsgw/bin/dosearch?context=default&hp=localhost&dn=uid%3
Ddougt%2Cou%3DPeople%2Cdc%3Dnetscape%2Cdc%3Dcom
Whoops! I wasn't using the commercial build.

I tried the non-working URL you cite in your last report.  I found that it
doesn't load on Mozilla, even when the cache is disabled.  Also, I tried loading
that URL using NN4, saved it out to disk and opened the saved version with
Mozilla.  The result was similarly truncated, so I'm guessing this is a
layout/parser problem.
Assignee: dougt → troy
Status: REOPENED → NEW
Component: Necko → Layout
Summary: Non-SSL phonebook doesn't work → [dogfood]Non-SSL phonebook doesn't work
assign to troy.
*** Bug 21594 has been marked as a duplicate of this bug. ***
there are two bugs here.. one is a parser bug, the other is a phonebook html
bug.  It stops parsing the page at:  "<![if ! IE 5]>"  (this is from their
HTML).  I'm not sure WTF this is supposed to do, but the parser shouldn't bail
here.  I'm also not sure how to file a bug against phonebook :)
Assignee: troy → rickg
Component: Layout → Parser
Based on pavlov's analysis (thanks pavlov) changing component and re-assigning
to parser (for the parser bug that he mentions)
Summary: [dogfood]Non-SSL phonebook doesn't work → [dogfood]phonebook doesn't work
Not an SSL problem, summary was triggering false matches
Status: NEW → ASSIGNED
Pavlov -- the parser bug looks trivial. Can you please send me the HTML file
that you used? (With the fragment "<![if ! IE 5]>").
The problem is fixed in my tree. I'm awaiting a review and approval to check it
in.
Whiteboard: [PDT+][dogfood] → [PDT+][dogfood] [12/19]
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Fixed by improvement to parser in dealing with cdata sections.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Searching for names in phonebook no longer produces an error message, but it
also doesn't find the names you search on.  Tried http:// and https:// with same
result.
(tried on linux and Win98 - same result)
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → INVALID
This bug is closed because the problem it describes was fixed (and remains
fixed). I'm closing this again, but doing Jan the favor of opening a new bug
that describes the new problem.
New bug rick filed is:
http://bugzilla.mozilla.org/show_bug.cgi?id=24317
Status: RESOLVED → VERIFIED
Thanks, marking this verified
You need to log in before you can comment on or make changes to this bug.