[e10s] Firefox crashes when a File is passed to a shared worker [@ mozilla::ipc::FatalError | mozilla::dom::PMessagePortParent::Read ]

RESOLVED WORKSFORME

Status

()

Core
DOM: Workers
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: kohei, Unassigned)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(e10s?, firefox45 affected)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Firefox crashes when a File is passed to a shared worker via MessagePort, while it doesn't crash with a dedicated worker. 100% reproducible.
(Reporter)

Updated

3 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 1

3 years ago
Here's my code:

https://github.com/bzdeck/bzdeck/blob/master/webroot/static/scripts/controllers/bug.js#L413

Firefox does not crash with a Blob. The same file actually has a shared worker that is passing a Blob, and it works fine:

https://github.com/bzdeck/bzdeck/blob/master/webroot/static/scripts/controllers/bug.js#L471

Firefox does not crash in a non-e10s window neither. Note: with non-e10s, drag-and-drop upload doesn't work on this app due to Bug 1188818.
Summary: Firefox crashes when a File is passed to a shared worker [@ mozilla::ipc::FatalError | mozilla::dom::PMessagePortParent::Read ] → [e10s] Firefox crashes when a File is passed to a shared worker [@ mozilla::ipc::FatalError | mozilla::dom::PMessagePortParent::Read ]
(Reporter)

Comment 2

3 years ago
Here's my shared worker, though the crash occurs regardless of the content of this script.

https://github.com/bzdeck/bzdeck/blob/master/webroot/static/scripts/workers/shared.js
tracking-e10s: --- → +
tracking-e10s: + → ?
Flags: needinfo?(mrbkap)
Kicking back into triage.
Flags: needinfo?(mrbkap)
I just tried to reproduce this without any success on both OSX and Linux trunk. Kohei, can you still reproduce this (and if so, a link to a testcase). I'm able to even read the data from the file.
Flags: needinfo?(kohei.yoshino)
Created attachment 8703933 [details]
shared.js

This is the shared worker.
Created attachment 8703934 [details]
testcase

Two methods of passing a File to a shared worker.

Both of these pass for me on OSX and Linux.
Those two files will have to be in the same directory somewhere in order to test this bug.
(Reporter)

Comment 8

2 years ago
Sorry I'm late here. Tested my code locally on the latest Nightly build with e10s enabled, and couldn't reproduce the crash this time. Maybe other bug has fixed the issue after I reported this. Will try to find the regression window (er, no, "fixed" window) when I have time. Thanks for your time anyway!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(kohei.yoshino)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.