'Show all bookmarks' is not closable once opened

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: churchman1993, Unassigned, NeedInfo)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8690646 [details]
Screen Shot 2015-11-23 at 12.33.05 AM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

Opened up window - "Show all bookmarks"


Actual results:

Brings up the functional bookmark/history window but gives no options to close it. Must restart browser.


Expected results:

It should have the ability to close the window

Comment 1

3 years ago
Markus, do you know what could cause the entire titlebar to be missing on mac?

Churchman, before you open the bookmarks manager could you open your browser console and check the console after to see if there are any messages? Also, do you have any addons or theems installed? Could you try this in safe mode or with a fresh profile to make sure this wasn't caused by any addons?
Component: Untriaged → Widget: Cocoa
Flags: needinfo?(mstange)
Flags: needinfo?(churchman1993)
Product: Firefox → Core
Looks like non-native fullscreen to me. Xidorn, do you know what could have happened here?
Flags: needinfo?(mstange) → needinfo?(quanxunzhen)
If that is non-native fullscreen, I suppose the exact STR would be:
1. make Firefox fullscreen
2. open the bookmarks manager (and the manager enter fullscreen automatically on 10.11)
3. switch back to Firefox and exit fullscreen
4. exit Firefox
5. open Firefox and open the bookmarks manager

Since Firefox 43, this STR would no longer work (which is fixed in bug 1137009). However, if you already have this broken state, it probably won't get fixed.

If that's the reason, a possible workaround is:
1. open Firefox
2. make Firefox fullscreen (the native fullscreen via Cmd-Shift-F)
3. open bookmarks manager (which should also enter fullscreen)
4. exit fullscreen from bookmarks manager
5. exit fullscreen from the browser window

We probably should also avoid loading fullscreen state from xulstore so that people already have the broken state could get it fixed automatically.
Flags: needinfo?(quanxunzhen)

Comment 4

3 years ago
(In reply to Xidorn Quan [:xidorn] (UTC+10) from comment #3)
> We probably should also avoid loading fullscreen state from xulstore so that
> people already have the broken state could get it fixed automatically.

Normally what we'd do in this circumstance is add a UI migration in nsBrowserGlue.js that kills off the broken stuff from XULStore.
On latest Nightly 49.0a1, 20160519030232, I can exit the bookmarks manager from full screen state and from normal state.  Just click the Red close window button.  In full screen you just have to mouse up to the top of the screen to get the window bar to appear for access to the Red button.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.