[Calendar]Calendar month views is in landscape mode and something is missing, when user backs from login Google account view in landscape.

RESOLVED WONTFIX
(NeedInfo from)

Status

Firefox OS
Gaia::Calendar
RESOLVED WONTFIX
3 years ago
4 months ago

People

(Reporter: Lance(leave from Mozilla), Unassigned, NeedInfo)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: [2.5-aries-test-run-4])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8690752 [details]
Bug log: logcat_1719.txt

[1.Description]:
[Flame KK v2.5&2.6][Aires KK v2.5&2.6]When users Add an Even, press the setting button and select Google and switch device to landscape mode. However, when user back from login Google account view, the Calendar month has been switched to landscape mode and something in this view is missing.
See log:"logcat_1719.txt"
See video:"Flame KK v2.6.3GP"
Found Time:"17:19"

[2.Testing Steps]: 
1. Open the Calendar app.
2. Tap the + button at the top right. 
3. Add an Event.
4. Tap the setting  button .
5. Select Add Account .
6. Select Google and switch device to landscape mode.
7. Back to Calendar month view.

[3.Expected Result]: 
4. Device is not in landscape mode and every view is displayed normally.

[4.Actual Result]: 
4. Month view has been switched to landscape mode and something is missing.

[5.Reproduction build]: 
Device: AriesKK master build (Affected):
Build ID               20151120061630
Gaia Revision          94a821b49f4dca3f9321cd80e13c44c4a6696952
Gaia Date              2015-11-19 15:35:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3835b568092ae3b71adc931d24928670ad7141a7
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151120.052332
Firmware Date          Fri Nov 20 05:23:39 UTC 2015
Bootloader             s1

Device: FlameKK master 512mb build (Affected):
Build ID               20151119224634
Gaia Revision          94a821b49f4dca3f9321cd80e13c44c4a6696952
Gaia Date              2015-11-19 15:35:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc325db44f6f8a58604d60b746c140e73f3d8216
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151119.220436
Firmware Date          Thu Nov 19 22:04:46 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: AriesKK v2.5 build (Affected):
Build ID               20151119161838
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/497118efc1414c2825a8bd17b38721888c3875ca
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151119.152025
Firmware Date          Thu Nov 19 15:20:33 UTC 2015
Bootloader             s1

Device: FlameKK v2.5 512mb build (Affected):
Build ID               20151119161153
Gaia Revision          28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gaia Date              2015-11-17 07:35:12
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/497118efc1414c2825a8bd17b38721888c3875ca
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151119.152146
Firmware Date          Thu Nov 19 15:21:56 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: FlameKK v2.2 512mb build (Unaffected):
Build ID               20151119032505
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e772f343b736
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151119.064750
Firmware Date          Thu Nov 19 06:48:01 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free test
(Reporter)

Updated

3 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+]
(Reporter)

Comment 1

3 years ago
Created attachment 8690762 [details]
Video: Flame KK v2.6.3GP
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+] → [MGSEI-Triage+]
(Reporter)

Updated

3 years ago
QA Whiteboard: [MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-v2.2: --- → unaffected
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+] → [MGSEI-Triage+]
Keywords: regression
Hi Alison,

Could you please have a check of this issue? thanks :)
Flags: needinfo?(ashiue)

Comment 3

3 years ago
Hi Gareth,

Could you please help to check this Calendar issue? Thank you.
Flags: needinfo?(ashiue) → needinfo?(gaye)
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
Assignee: nobody → liuke
QA Contact: liuke
(Reporter)

Updated

3 years ago
Assignee: liuke → nobody

Updated

3 years ago
QA Contact: liuke → jthomas

Comment 4

3 years ago
Caused by changes made in Bug 1131470

Mozilla Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150818201141
Gaia: 1e1197e0e8e64307aa382ffba4711d1c661de7ca
Gecko: 4203e86db40a2fdcc52fa2f6ca263a1d9d704b91
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150818201542
Gaia: 1e1197e0e8e64307aa382ffba4711d1c661de7ca
Gecko: be65c38abed995c7975383836c87df21ac02bcc7
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working gaia / First Broken gecko - This issue DOES occur with broken Gecko
Gaia: 1e1197e0e8e64307aa382ffba4711d1c661de7ca
Gecko: be65c38abed995c7975383836c87df21ac02bcc7

Last Working gecko / First Broken gaia - This issue does NOT occur with broken Gaia
Gecko: 4203e86db40a2fdcc52fa2f6ca263a1d9d704b91
Gaia: 1e1197e0e8e64307aa382ffba4711d1c661de7ca

Mozilla Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4203e86db40a2fdcc52fa2f6ca263a1d9d704b91&tochange=be65c38abed995c7975383836c87df21ac02bcc7
Blocks: 1131470
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
William this issue seems to have bee caused by the changes for bug 1131470.  Can you please take a look?
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage?] → [MGSEI-Triage+][QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(wchen)
Flags: needinfo?(wchen)

Comment 6

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.